[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] Cannot get m2e to show up after installing into Indigo SR2

m2e (core) does not directly support jee development, so jee distro is
not our primary test target. We also do not troubleshoot m2e in the
context of thirdparty and/or custom distributions.

Having said that, I just checked m2e 1.1 installs and works with
clean/fresh eclipse 3.7.2 jee distro.

Btw, if you or other m2e users are interested in doing ongoing testing
of m2e with jee or other disto, feel free join m2e-dev mailing list and
report any incompatibilities you find there. We also always provide few
days for community testing of milestone and release builds, so check
either m2e-dev or m2e-users for announcement emails.

--
Regards,
Igor

On 12-07-03 2:41 PM, Mark Streit wrote:
We use Eclipse for JEE Developers (not Classic) - could that be the
problem?  And if so, that puzzles me since more folks use that JEE
version of Eclipse.
http://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/indigosr2


Look at the number of downloads compared to Classic. Almost 3.5 times more than Classic. Am I misunderstanding?

Thanks

On Tue, Jul 3, 2012 at 2:13 PM, Igor Fedorenko <igor@xxxxxxxxxxxxxx
<mailto:igor@xxxxxxxxxxxxxx>> wrote:

    Yes, this is correct URL and I just verified that I was able to use that
    URL to install m2e 1.1 onto fresh/clean Eclipse 3.7.2 "Classic"
    distribution and m2e appears to work after the install.

    At this point I will have to assume the problem is specific to your
    environment and/or caused by incompatibility between m2e and some other
    Eclipse plugins you have installed.

    The best advice I can give is to start with fresh eclipse install and
    install additional plugins one by one to see at what point it breaks

    --
    Regards,
    Igor


On 12-07-03 12:25 PM, Mark Streit wrote:

        Igor

        Is there a special way to get the 1.1 release - I just pointed
        to the
        URL when setting up the location as stated in the original email
        and it
        installed what I showed.  Am I using the wrong URL?
        http://download.eclipse.org/__technology/m2e/releases
        <http://download.eclipse.org/technology/m2e/releases>

        So if this does not work - is it in fact an Indigo-specific
        issue with
        regard to this OSGI stuff - I installed what came from the Eclipse
        site.  It does have a few other plugins, one being some Android
        tools
        plug-in which I am not using much at this point.  There is an OSGi
        Application Development Tools bundle that is installed (IBM).  I had
        installed an IBM WAS 8.5 Liberty connector earlier but not sure
        what put
        that OSGi bundle in there or was it part of the Indigo OOTB
        install - I
        did not check that.

        Thanks again for the input.

        On Tue, Jul 3, 2012 at 11:44 AM, Igor Fedorenko
        <igor@xxxxxxxxxxxxxx <mailto:igor@xxxxxxxxxxxxxx>
        <mailto:igor@xxxxxxxxxxxxxx <mailto:igor@xxxxxxxxxxxxxx>>> wrote:

             Looks like OSGi runtime is not able to resolve and/or start
        m2e bundles,
             which may be related to log messages about OSGi bundle
        activation
             deadlock. Can't tell anything more specific without steps
        to reproduce
             the problem locally.

             May be worth trying m2e 1.1, but can't promise it will help.

             --
             Regards,
             Igor


On 12-07-03 11:01 AM, Mark Streit wrote:

                 Files attached...only a few lines in the .log show anything
                 related to m2e.

                 Thanks


On Tue, Jul 3, 2012 at 12:40 AM, Igor Fedorenko <igor@xxxxxxxxxxxxxx <mailto:igor@xxxxxxxxxxxxxx> <mailto:igor@xxxxxxxxxxxxxx <mailto:igor@xxxxxxxxxxxxxx>> <mailto:igor@xxxxxxxxxxxxxx <mailto:igor@xxxxxxxxxxxxxx> <mailto:igor@xxxxxxxxxxxxxx <mailto:igor@xxxxxxxxxxxxxx>>>> wrote:

                      Anything interesting in .metadata/.log? Can you
        attach your
                 eclipse
                      configuration? Both m2e 1.0 and 1.1 are expected
        to work
                 with Indigo.
                      --
                      Sent from my SGS

                      Mark Streit <mcs130@xxxxxxxxx
        <mailto:mcs130@xxxxxxxxx> <mailto:mcs130@xxxxxxxxx
        <mailto:mcs130@xxxxxxxxx>>
                 <mailto:mcs130@xxxxxxxxx <mailto:mcs130@xxxxxxxxx>
        <mailto:mcs130@xxxxxxxxx <mailto:mcs130@xxxxxxxxx>>>> wrote:

                       >Hello
                       >
                       >Since the forum was closed, I understand that
        this is the
                 mailing list
                       >to
                       >be used for questions.  I am hoping this is a simple
                 question.
                       >
                       >1) I am running Eclipse Indigo SR2 which is all
        up to
                 date for the
                       >current
                       >core and Subclipse.  (Eclipse for JEE Developers
        was the
                 package
                       >installed)
                       >2) Running Win 7 / 32 bit
                       >3) Using the "Install new software" option, I
        define a
                 site using the
                       >following value:
        http://download.eclipse.org/____technology/m2e/releases
        <http://download.eclipse.org/__technology/m2e/releases>

                 <http://download.eclipse.org/__technology/m2e/releases
        <http://download.eclipse.org/technology/m2e/releases>>
                       >4) It finds the m2e component, I successfully
        install the
                 plug-in, and
                       >after clicking the Installation Details button
        on the
                 About Eclipse
                       >dialog... I see this in my list.  So far so
        good.... so I
                 thought.
                       >
                       >*  m2e - Maven Integration for Eclipse
          1.0.0.20110607-2117
                       >org.eclipse.m2e.feature.____feature.group
          Eclipse.org - m2e*

                       >
                       >I restart the workbench ... however, there is no
        evidence
                 in the IDE
                       >that
                       >this plug-in is even there.  Clicking
        *Preferences *-
                 there is no
                      Maven
                       >entry to configure as I would have expected.  I have
                 googled and found
                       >a
                       >number of links that point to "converting project to
                 Maven" or
                      manually
                       >messing with .launch files.  However, none of
        these seem
                 applicable -
                       >there
                       >are no enabled Maven options showing up on any
        menus.
                       >
                       >Any suggestion would be appreciated.  Installed
        Juno -
                 the m2e
                       >installed
                       >OK, but there were numerous other issues we
        found with
                 Juno that
                      caused
                       >us
                       >to drop and revert back to Indigo for now.
          Simple things
                 like "Reset
                       >Perspective..." sent the Juno installation into
        a mess -
                 the IDE
                       >rendered
                       >with Views misplaced - wide gaps between the
        views, Ant
                 Editor and JS
                       >Editors that would pop up exception dialogs,
        etc.  Juno
                 is NOT an
                       >option
                       >for us now.
                       >
                       >Thanks
                       >
                       >Mark
                       >___________________________________________________

                       >m2e-users mailing list
                       >m2e-users@xxxxxxxxxxx
        <mailto:m2e-users@xxxxxxxxxxx> <mailto:m2e-users@xxxxxxxxxxx
        <mailto:m2e-users@xxxxxxxxxxx>>
                 <mailto:m2e-users@xxxxxxxxxxx
        <mailto:m2e-users@xxxxxxxxxxx> <mailto:m2e-users@xxxxxxxxxxx
        <mailto:m2e-users@xxxxxxxxxxx>>__>


>https://dev.eclipse.org/____mailman/listinfo/m2e-users <https://dev.eclipse.org/__mailman/listinfo/m2e-users> <https://dev.eclipse.org/__mailman/listinfo/m2e-users <https://dev.eclipse.org/mailman/listinfo/m2e-users>>

                      ___________________________________________________

                      m2e-users mailing list
        m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx>
        <mailto:m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx>>
                 <mailto:m2e-users@xxxxxxxxxxx
        <mailto:m2e-users@xxxxxxxxxxx> <mailto:m2e-users@xxxxxxxxxxx
        <mailto:m2e-users@xxxxxxxxxxx>>__>
        https://dev.eclipse.org/____mailman/listinfo/m2e-users
        <https://dev.eclipse.org/__mailman/listinfo/m2e-users>
                 <https://dev.eclipse.org/__mailman/listinfo/m2e-users
        <https://dev.eclipse.org/mailman/listinfo/m2e-users>>



                 ///

                 /


___________________________________________________

                 m2e-users mailing list
        m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx>
        <mailto:m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx>>
        https://dev.eclipse.org/____mailman/listinfo/m2e-users
        <https://dev.eclipse.org/__mailman/listinfo/m2e-users>
                 <https://dev.eclipse.org/__mailman/listinfo/m2e-users
        <https://dev.eclipse.org/mailman/listinfo/m2e-users>>


___________________________________________________

             m2e-users mailing list
        m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx>
        <mailto:m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx>>
        https://dev.eclipse.org/____mailman/listinfo/m2e-users
        <https://dev.eclipse.org/__mailman/listinfo/m2e-users>
             <https://dev.eclipse.org/__mailman/listinfo/m2e-users
        <https://dev.eclipse.org/mailman/listinfo/m2e-users>>





        /
        /


_________________________________________________ m2e-users mailing list m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx> https://dev.eclipse.org/__mailman/listinfo/m2e-users <https://dev.eclipse.org/mailman/listinfo/m2e-users>


_________________________________________________ m2e-users mailing list m2e-users@xxxxxxxxxxx <mailto:m2e-users@xxxxxxxxxxx> https://dev.eclipse.org/__mailman/listinfo/m2e-users <https://dev.eclipse.org/mailman/listinfo/m2e-users>




/ /


_______________________________________________ m2e-users mailing list m2e-users@xxxxxxxxxxx https://dev.eclipse.org/mailman/listinfo/m2e-users