[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-users] how to force refresh of local repo content?

I use tycho 0.14.1, m2e 1.1.0.20120130-2016 with tycho project configurators 0.6.0.201112050222 on top of eclipse classic Juno M6.

Regards,
Jan

-----Original Message-----
From: m2e-users-bounces@xxxxxxxxxxx [mailto:m2e-users-bounces@xxxxxxxxxxx] On Behalf Of Igor Fedorenko
Sent: Freitag, 23. März 2012 16:26
To: m2e-users@xxxxxxxxxxx
Subject: Re: [m2e-users] how to force refresh of local repo content?

What version of m2e do you use?

Do you use snapshot or release version of tycho?

--
Regards,
Igor

On 12-03-23 9:28 AM, Sievers, Jan wrote:
> Hi,
>
> for the EclipseCON tycho tutorial we provide a pre-filled local maven repo as we can't rely on WiFi.
>
> If I copy the pre-filled repo to ~/.m2/repository/ after eclipse was started, it seems there is no way of refreshing the local repo index used by m2e.
>
> Initially I get an m2e error marker "Project build error: Unknown packaging: eclipse-plugin" which is consistent with the headless build failure.
>
> After the pre-filled local repo content is copied, I can build fine (Run As>  Maven install succceeds), but the error markers don't go away.
>
> I tried several options to force a local repo refresh (Window>  Preferences>  Maven>  User Settings>  Reindex local repository, Maven>  Update Project on the project), but no success.
>
> For now the only option to get rid of the outdated error markers seems to restart the IDE.
>
> How is refreshing for local repo changes coming from outside the IDE supposed to work in m2e?
>
> Thanks,
> Jan
>
>
> _______________________________________________
> m2e-users mailing list
> m2e-users@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/m2e-users
_______________________________________________
m2e-users mailing list
m2e-users@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/m2e-users