[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [m2e-dev] Major fix for m2eclipse-wtp to test

I upgraded to the latest 0.12 build to help test and I am now getting
a new error that may or may not be related.

Helios 3.6.2

I am getting the following error in one of my poms:

Description	Resource	Path	Location	Type
Guice provision errors:

1) No implementation for org.apache.maven.plugin.Mojo annotated with
was bound.

1 error	pom.xml	/svn-rm-deploy	line 1	Maven Problem

I've never seen this error before I upgraded to m2e-wtp  The previous m2e-wtp version I was using was

This appears to be caused because I am using the
org.maven.ide.eclipse:lifecycle-mapping plugin to only execute the
"maven-resources-plugin".  Thoughts?  Could your recent change have
caused this? Here is my profile snippet:

id="org.maven.ide.eclipse.configuration.wtp.configurator" />


On Thu, Apr 14, 2011 at 10:45 AM, Fred Bricon <fbricon@xxxxxxxxx> wrote:
> Hi,
> I've just added a modification which I believe might fix most NPEs people
> get during project import or configuration. ([1], [2], [3], [4]) It will
> also help removing test classes and resources that sometimes get deployed
> with your app [5].
> So if you can, I strongly encourage you to test the latest CI build
> available under
> https://repository.sonatype.org/content/sites/forge-sites/m2eclipse-wtp/0.12.0/N/<latest_directory>
> and give me your feedback, I can't reproduce said bugs
> 0.12.0 is closing in :-)
> regards,
> Fred Bricon
> [1] https://issues.sonatype.org/browse/MECLIPSEWTP-3
> [2] https://issues.sonatype.org/browse/MECLIPSEWTP-14
> [3] https://issues.sonatype.org/browse/MECLIPSEWTP-41
> [4] https://issues.sonatype.org/browse/MECLIPSEWTP-42
> [5] https://issues.sonatype.org/browse/MECLIPSEWTP-7
> --
> "Have you tried turning it off and on again" - The IT Crowd
> _______________________________________________
> m2e-dev mailing list
> m2e-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/m2e-dev