[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [libra-dev] Oxygen Update Site?

Hi Kaloyan,


thanks for fixing the composite-* jars.

Actually, I have two questions:

1) what needs to be done to have Eclipse automatically install the correct Libra release depending on the PDE version?
(0.3.0 for Mars, 0.3.1 for Neon, 'latest' for Oxygen)
Would it be sufficient to restrict the Require-Bundle directives?
-> this would mean fixing the respective branches and doing a new release for each of the maintainance branches.


2) in pom.xml, a number of p2 repos are specified with specific builds. I guess each of these should be updated to a corresponding stable release repo (at least during the simultaneous release days)?
( http://git.eclipse.org/c/libra/org.eclipse.libra.git/tree/development/org.eclipse.libra.releng/pom.xml )



The bump to 0.3.3 was probably not quite intentional, I think it would be more sensible to use 0.3.2 for Oxygen und 0.3.3 for Pluto.



Thanks again & best regards,

	-hannes





On 2017-05-22 09:18, Kaloyan Raev wrote:
Hi Hannes,

The compositeArtifacts.jar and compositeContent.jar files in the
http://download.eclipse.org/libra/releases/ location were not updated
with the 0.3.1 release. I've just done this.

The latest nightly (from Nov 2016) should be compatible with Oxygen -
it builds successfully and all test pass...
But, is it necessary to (constantly?) update all the paths to the
Oxygen milestone drops? I'm confused what needs to be done in order to
provide working p2 repos.

I am not sure what you mean here. If you need a p2 repo for the latest
nightly build from master, just use this one:
http://download.eclipse.org/libra/nightly

BTW, I noticed that the latest commit in master switched the version
from 0.3.2 to 0.3.3. Does this mean that we were done with 0.3.2 at that
moment? If yes, then we will need to release a version 0.3.2 from the
previous commit.

Kaloyan Raev| Zend Studio Team Lead
Rogue Wave Software, Inc.
Innovate with Confidence
*M* +359 887 648 663
www.roguewave.com <http://www.roguewave.com> / kaloyan.raev@xxxxxxxxxxxxx

On 05/20/2017 03:48 AM, Hannes Erven wrote:
Hi Kaloyan,


could you please help with fixing the update site?

In a fresh 4.7 M6 install, adding
http://download.eclipse.org/libra/releases/ results in 0.3.0 being
installed, despite 0.3.1 being available in /latest .

However, none of these builds are suitable for Oxygen. In fact, we
should make probably sure that the builds know their dependencies:
0.3.0 -> Luna
0.3.1 -> Neon
0.3.3 -> Oxygen (current master)

The latest nightly (from Nov 2016) should be compatible with Oxygen -
it builds successfully and all test pass...
But, is it necessary to (constantly?) update all the paths to the
Oxygen milestone drops? I'm confused what needs to be done in order to
provide working p2 repos.


Thanks for your help! Best regards,

    -hannes
_______________________________________________
libra-dev mailing list
libra-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or
unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/libra-dev



_______________________________________________ libra-dev mailing list libra-dev@xxxxxxxxxxx To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/libra-dev