[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [jwt-dev] Selecting Action as a target model element in the aspect properties

Hi Samir

OK, if you're registered then please reply to the mailing list rather than to me :)


Sorry, as I've answered to Deena, " There may be some bugs in the conf editor...

I suggest you open your conf file and your custom ecore model on a text editor, compare to working examples like logging (*) and property (**), and patch them as needed.

(*)
http://dev.eclipse.org/svnroot/soa/org.eclipse.jwt/trunk/examples/jwt-we-sample-logging/conf/
http://dev.eclipse.org/svnroot/soa/org.eclipse.jwt/trunk/examples/jwt-we-sample-logging/model/

(**)
http://dev.eclipse.org/svnroot/soa/org.eclipse.jwt/trunk/we/jwt-we-conf-property-model/samples/
http://dev.eclipse.org/svnroot/soa/org.eclipse.jwt/trunk/we/jwt-we-conf-property-model/model/
"

In addition, I suggest that rather than starting from scratch, you start from a working example and you modify it for your needs.

Hope it helps !

Regards,
Marc

Le 25/05/2011 15:40, Ahmed Samir Saleh Wafa a écrit :
Dear Marc,

Some bugs came up so I had to do my work one more time. Anyway, this time, when I create an aspect, I need to specify that the target model element is Action, but I can't find it in the list. I try to add the package containing it (org.eclipse.jwt/processes) but it just doesn't get added. What am I doing wrong ??


p.s: I thought I was registered to the jwt mailing list. What should I do to get registered ??


best regards, samir