[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[jetty-dev] imported into intellij, built successfully, error when running in debug

So I placed a breakpoint in the main method to follow along in the fun :)

I got this error:

Connected to the target VM, address: '127.0.0.1:61946', transport: 'socket'
java.lang.ClassNotFoundException: org.eclipse.jetty.xml.XmlConfiguration
at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
at org.eclipse.jetty.start.Main.invokeMain(Main.java:424)
at org.eclipse.jetty.start.Main.start(Main.java:602)
at org.eclipse.jetty.start.Main.main(Main.java:82)
ClassNotFound: org.eclipse.jetty.xml.XmlConfiguration

Usage: java -jar start.jar [options] [properties] [configs]
       java -jar start.jar --help  # for more information
Disconnected from the target VM, address: '127.0.0.1:61946', transport: 'socket'

Process finished with exit code 254


Which occurred here:
try
        {
            invoked_class = classloader.loadClass(classname);
        }
        catch (ClassNotFoundException e)
        {
            e.printStackTrace();
        }


I'm a bit confused as to why the main method is "org.eclipse.jetty.xml.XmlConfiguration" and not the org.eclipse.jetty.start main() but I guess I'll understand that once I can get jetty to start w/o errrors.

Any tips?  I can't wait till I can debug a request.....

thanks in advance.