[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [ide4edu-dev] work environment setup

Well drat!

I just noticed that the team project set wasn't updated correctly. You've loaded the code from an old repository (which should have been archived a long time ago).

I apologise for this oversight.

The explanation here is that we moved the project some time ago. But, it seems, I neglected to update the team project set to point to the new repository. Generally, we keep an old repository around for a little while to help with the transition. The old one is read-only.

I've attached the correct team project set; I've updated the wiki (though some caching is preventing it from being available immediately) and will update the project site later today.

Wayne


Aditya Kumar wrote:
Hi,

I am using Eclipse Classic now (I installed RCP/Plugin development version too, and had the same issues). I downloaded a fresh copy of the code and in addition to the previous errors, I am getting 4 more errors now. NewJavaLiteProjectWizardPackageTwo.java is complaining about setCompilanceOptions and enableAutoBuild method calls. Total 6 build errors.

And yes, I did try what Wayne suggested -- setting up the target platform as running platform (It was already checked).

Aditya



----- Original Message ----
From: Wayne Beaton <wayne@xxxxxxxxxxx>
To: Eclipse IDE for Education <ide4edu-dev@xxxxxxxxxxx>
Sent: Saturday, September 19, 2009 1:00:02 AM
Subject: Re: [ide4edu-dev] work environment setup

Ian, these changes have been committed AFAIK. Please update what you have in your workspace and confirm.

Wayne

Ian Kennedy wrote:
These changes will fix your issues. All changes commented as // ianck

-Ian

On Fri, Sep 18, 2009 at 3:02 PM, Wayne Beaton <wayne@xxxxxxxxxxx <mailto:wayne@xxxxxxxxxxx>> wrote:

    Please confirm what Eclipse IDE you're using. I hope that you have
    the Eclipse IDE for Plug-in/RCP Developers

    Are you working from the same workspace that you set up previously?

    Try this:

    Open the preferences and navigate to "Plug-in Development > Target
    Platform". Highlight the "Running Platform", make sure that there
    is a check to the left, and click "Reload..."

    If this actually works, I may try to explain why...

    Wayne



    Aditya Kumar wrote:

        Hi,

        In my previous email I mentioned that my work environment
        setup has been facing an issue. I have been checking my email
        in hope for a reply.

        Anyway,  Now that I have the right Eclipse IDE version, and I
        have downloaded the code, I am seeing errors in
        NewJavaLiteProjectWizardPageTwo and
        NewJavaLiteProjectWizardPageOne files, with
        "JavaWorkingSetUpdater.ID can't be resolved" error.

        Does someone know, what is wrong here? Any help will be
        greatly appreciated.

        Thanks
        Aditya Kumar


_______________________________________________
ide4edu-dev mailing list
ide4edu-dev@xxxxxxxxxxx <mailto:ide4edu-dev@xxxxxxxxxxx>
https://dev.eclipse.org/mailman/listinfo/ide4edu-dev


    _______________________________________________
    ide4edu-dev mailing list
   ide4edu-dev@xxxxxxxxxxx <mailto:ide4edu-dev@xxxxxxxxxxx>
   https://dev.eclipse.org/mailman/listinfo/ide4edu-dev


------------------------------------------------------------------------

_______________________________________________
ide4edu-dev mailing list
ide4edu-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/ide4edu-dev
_______________________________________________
ide4edu-dev mailing list
ide4edu-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/ide4edu-dev





_______________________________________________
ide4edu-dev mailing list
ide4edu-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/ide4edu-dev
<?xml version="1.0" encoding="UTF-8"?>
<psf version="2.0">
<provider id="org.eclipse.team.cvs.core.cvsnature">
<project reference="1.0,:pserver:dev.eclipse.org:/cvsroot/technology,org.eclipse.ide4edu/javalite/features/org.eclipse.ide4edu.javalite.feature,org.eclipse.ide4edu.javalite.feature"/>
<project reference="1.0,:pserver:dev.eclipse.org:/cvsroot/technology,org.eclipse.ide4edu/javalite/plugins/org.eclipse.ide4edu.javalite.ui,org.eclipse.ide4edu.javalite.ui"/>
</provider>
</psf>