[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [iam-dev] Updated target platform script

ah, ok, so it's not going to download the SR2 bundles, you need to do that first

got 3.4.2 for osx eclipse-SDK-3.4.2-macosx-carbon.tar.gz
deleted old eclipse folder, run again, got this error

     [exec] Command-line arguments:  -os macosx -ws carbon -arch x86
-clean -consoleLog -data
/Users/csanchez/dev/iam/iam/dev-tools/workspace -application
org.eclipse.equinox.p2.director.app.application -metadataRepository
http://download.eclipse.org/releases/ganymede/ -artifactRepository
http://download.eclipse.org/releases/ganymede/ -installIU
org.eclipse.jdt.feature.group -version
3.4.1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97
-profileProperties org.eclipse.update.install.features=true
     [exec]
     [exec] !ENTRY org.eclipse.core.net 1 0 2009-03-04 17:45:22.727
     [exec] !MESSAGE System property http.nonProxyHosts has been set
to local|*.local|169.254/16|*.169.254/16 by an external source. This
value will be overwritten using the values from the preferences
     [exec] Installing org.eclipse.jdt.feature.group
3.4.1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97.
     [exec]
     [exec] !ENTRY org.eclipse.equinox.p2.director 4 0 2009-03-04 17:45:30.331
     [exec] !MESSAGE Problems resolving provisioning plan.
     [exec] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2009-03-04
17:45:30.332
     [exec] !MESSAGE No solution found because the problem in
/tmp/p2Encoding34291.opb is unsatisfiable.
     [exec] Installation failed.
     [exec]
     [exec] !ENTRY org.eclipse.equinox.p2.director 4 1 2009-03-04 17:45:30.667
     [exec] !MESSAGE Cannot find a solution satisfying the following
requirements org.eclipse.debug.ui [3.4.1.v20080811_r341].


still see a reference to 3.4.1 in the ant file for JDT


2009/3/4 Abel Muiño <amuino@xxxxxxxxx>:
> What are you using as the base Eclipse?
>
> I tested with a matching 3.4SR2 SDK.
>
> On Wed, Mar 4, 2009 at 7:22 PM, Carlos Sanchez <carlossg@xxxxxxxxx> wrote:
>>
>> getting errors here
>>
>>     [echo]
>>     [echo] Installing Ganymede Plugin: Buckminster
>>     [exec] !SESSION 2009-03-04 10:20:32.524
>> -----------------------------------------------
>>     [exec] eclipse.buildId=M20080911-1700
>>     [exec] java.version=1.5.0_16
>>     [exec] java.vendor=Apple Inc.
>>     [exec] BootLoader constants: OS=macosx, ARCH=x86, WS=carbon, NL=en_US
>>     [exec] Framework arguments:  -application
>> org.eclipse.equinox.p2.director.app.application -metadataRepository
>> http://download.eclipse.org/releases/ganymede/ -artifactRepository
>> http://download.eclipse.org/releases/ganymede/ -installIU
>> org.eclipse.buckminster.core.feature.feature.group -version
>> 1.1.0.r09948 -profileProperties
>> org.eclipse.update.install.features=true
>>     [exec] Command-line arguments:  -os macosx -ws carbon -arch x86
>> -clean -consoleLog -data
>> /Users/csanchez/dev/iam/iam/dev-tools/workspace -application
>> org.eclipse.equinox.p2.director.app.application -metadataRepository
>> http://download.eclipse.org/releases/ganymede/ -artifactRepository
>> http://download.eclipse.org/releases/ganymede/ -installIU
>> org.eclipse.buckminster.core.feature.feature.group -version
>> 1.1.0.r09948 -profileProperties
>> org.eclipse.update.install.features=true
>>     [exec]
>>     [exec] !ENTRY org.eclipse.core.net 1 0 2009-03-04 10:20:36.946
>>     [exec] !MESSAGE System property http.nonProxyHosts has been set
>> to local|*.local|169.254/16|*.169.254/16 by an external source. This
>> value will be overwritten using the values from the preferences
>>     [exec] Installing
>> org.eclipse.buckminster.core.feature.feature.group 1.1.0.r09948.
>>     [exec]
>>     [exec] !ENTRY org.eclipse.equinox.p2.director 4 0 2009-03-04
>> 10:20:47.386
>>     [exec] !MESSAGE Problems resolving provisioning plan.
>>     [exec] !SUBENTRY 1 org.eclipse.equinox.p2.director 4 0 2009-03-04
>> 10:20:47.386
>>     [exec] !MESSAGE No solution found because the problem in
>> /tmp/p2Encoding61901.opb is unsatisfiable.
>>     [exec] Installation failed.
>>     [exec]
>>     [exec] !ENTRY org.eclipse.equinox.p2.director 4 1 2009-03-04
>> 10:20:48.437
>>     [exec] !MESSAGE Cannot find a solution satisfying the following
>> requirements Match[requiredCapability:
>>
>> org.eclipse.equinox.p2.iu/org.eclipse.debug.ui/[3.4.0.v20080529-1300,3.4.0.v20080529-1300]].
>>
>> BUILD FAILED
>> /Users/csanchez/dev/iam/iam/dev-tools/iam-prep-target-platform.xml:85:
>> The following error occurred while executing this line:
>> /Users/csanchez/dev/iam/iam/dev-tools/iam-prep-target-platform.xml:204:
>> The following error occurred while executing this line:
>> /Users/csanchez/dev/iam/iam/dev-tools/iam-prep-target-platform.xml:146:
>> The following error occurred while executing this line:
>> /Users/csanchez/dev/iam/iam/dev-tools/iam-prep-target-platform.xml:104:
>> exec returned: 13
>>
>>
>> 2009/3/4 Abel Muiño <amuino@xxxxxxxxx>:
>> - Show quoted text -
>> > FYI:
>> > The features on the ganymede update site have changed now that the SR2
>> > release is out.
>> >
>> > I have updated the target platform creation script to work with the new
>> > versions (since it was failing).
>> > This is a maintenance release, so I would not change the minimum
>> > versions
>> > already set for IAM plug-ins.
>> >
>> > Lesson learned: we can not reliably depend on the "public" update site.
>> > Maybe the projects' update sites are more stable?
>> > --
>> > Abel Muiño - http://ramblingabout.wordpress.com/
>> >
>> > _______________________________________________
>> > iam-dev mailing list
>> > iam-dev@xxxxxxxxxxx
>> > https://dev.eclipse.org/mailman/listinfo/iam-dev
>> >
>> >
>> _______________________________________________
>> iam-dev mailing list
>> iam-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/iam-dev
>
>
>
> --
> Abel Muiño - http://ramblingabout.wordpress.com/
>
> _______________________________________________
> iam-dev mailing list
> iam-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/iam-dev
>
>