[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[gef3d-dev] GEF3D build Fwd: Build failed in Hudson: amp-nightly #1123


Hi guys,

Looks like we have a GEF3D related error here:

Begin forwarded message:

Date: September 9, 2011 2:14:28 PM PDT
Subject: Build failed in Hudson: amp-nightly #1123

See <https://hudson.eclipse.org/hudson/job/amp-nightly/1123/>

------------------------------------------
[...truncated 1159 lines...]
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/intersection/PolylineIntersectsPolylineAlgorithm.java,> line 134: The method addOverlap(PolylineIntersectsPolylineAlgorithm.TreeSegment) from the type PolylineIntersectsPolylineAlgorithm.TreeSegment is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/intersection/PolylineIntersectsPolylineAlgorithm.java,> line 153: The method removeOverlap(PolylineIntersectsPolylineAlgorithm.TreeSegment) from the type PolylineIntersectsPolylineAlgorithm.TreeSegment is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/intersection/PolylineIntersectsPolylineAlgorithm.java,> line 161: The method getPolyline() from the type PolylineIntersectsPolylineAlgorithm.TreeSegment is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/intersection/PolylineIntersectsPolylineAlgorithm.java,> line 450: The field PolylineIntersectsPolylineAlgorithm.m_intersections is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/intersection/AVLTree.java,> line 460: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/Math3DMatrix4f.java,> line 411: Dead code
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/Math3DMatrix4f.java,> line 414: Dead code
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/Math2D.java,> line 24: The type Math2D.VertexComparator is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry/src/java/org/eclipse/draw3d/geometry/Math2D.java,> line 28: The constructor Math2D.VertexComparator(int[]) is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.geometry>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.graphics3d/src/java/org/eclipse/draw3d/graphics3d/Graphics3DDescriptor.java,> line 154: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.graphics3d/src/java/org/eclipse/draw3d/graphics3d/DisplayListManager.java,> line 63: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.graphics3d>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/util/ImageConverter.java,> line 403: The local variable fgAlphaByte is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/util/DebugPrimitives.java,> line 175: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/shapes/ParaxialBoundsFigureShape.java,> line 19: The import org.eclipse.draw3d.geometry.Math3DCache is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/picking/Query.java,> line 242: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/picking/Query.java,> line 203: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/picking/Query.java,> line 213: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/picking/Query.java,> line 215: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/picking/GeometryPicker.java,> line 34: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/offscreen/OffscreenRenderer.java,> line 16: The import org.eclipse.draw3d.RenderContext is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 215: The method setX(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 216: The method setY(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 217: The method setWidth(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 218: The method setHeight(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 642: The method setX(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 643: The method setY(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 644: The method setWidth(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/graphics/GraphicsState.java,> line 645: The method setHeight(double) from the type PrecisionRectangle is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/geometryext/PointList3D.java,> line 260: The constructor Point(double, double) is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/geometryext/PointList3D.java,> line 24: The import org.eclipse.draw3d.Polyline3D is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/draw2dports/FreeformHelper.java,> line 89: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/draw2dports/FreeformHelper.java,> line 163: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/camera/tracking/TrackingUtil.java,> line 14: The import org.eclipse.draw2d.geometry.Dimension is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/camera/tracking/TrackingShot.java,> line 32: The field TrackingShot.log is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/camera/tracking/TrackingShot.java,> line 13: The import java.util.logging.Level is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/camera/tracking/LinearMovement.java,> line 17: The import org.eclipse.draw3d.geometry.Math3DCache is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/camera/AbstractCameraPosition.java,> line 14: The import org.eclipse.draw3d.geometry.Vector3f is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/XYZLayout.java,> line 25: The import org.eclipse.draw3d.geometry.Math3DCache is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/XYZLayout.java,> line 17: The import org.eclipse.draw2d.LayoutManager is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/XYZAnchor.java,> line 82: The constructor Point(double, double) is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/StackLayout3D.java,> line 15: The import org.eclipse.draw3d.geometry.IVector3f is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/StackLayout3D.java,> line 16: The import org.eclipse.draw3d.geometry.Math3D is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/StackLayout3D.java,> line 17: The import org.eclipse.draw3d.geometry.Position3D is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/StackLayout3D.java,> line 18: The import org.eclipse.draw3d.geometry.Position3DUtil is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 14: The import java.util.Collection is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 249: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 252: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 252: Type safety: The constructor ArrayList(Collection) belongs to the raw type ArrayList. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 252: ArrayList is a raw type. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 253: Type safety: The method addAll(Collection) belongs to the raw type List. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 637: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/LightweightSystem3D.java,> line 724: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/FreeformLayer3D.java,> line 127: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/Figure3DHelper.java,> line 189: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/Figure3DHelper.java,> line 386: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/Figure3DHelper.java,> line 720: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/FeedbackLayer3D.java,> line 13: The import org.eclipse.draw2d.Connection is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/FeedbackLayer3D.java,> line 15: The import org.eclipse.draw2d.IFigure is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/DispatchingConnectionLayerHelper.java,> line 244: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw3d/DispatchingConnectionLayerHelper.java,> line 246: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw2d/EventDispatcher3D.java,> line 16: The import org.eclipse.draw2d.geometry.Point is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw2d/EventDispatcher3D.java,> line 22: The import org.eclipse.draw3d.geometry.Math3D is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw2d/EventDispatcher3D.java,> line 25: The import org.eclipse.draw3d.util.Draw3DCache is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d/src/java/org/eclipse/draw2d/EventDispatcher3D.java,> line 52: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/texture/AbstractLwjglTexture.java,> line 13: The import org.eclipse.draw2d.Graphics is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/texture/AbstractLwjglTexture.java,> line 14: The import org.eclipse.draw3d.graphics3d.lwjgl.graphics.LwjglGraphics is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/texture/AbstractLwjglTexture.java,> line 15: The import org.eclipse.swt.graphics.Color is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/graphics/LwjglTextVBO.java,> line 232: The local variable text is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/graphics/LwjglTextVBO.java,> line 233: The local variable expand is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/graphics/LwjglTextVBO.java,> line 235: The local variable transformation is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/graphics/LwjglTextVBO.java,> line 234: The local variable position is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/graphics/LwjglGraphics.java,> line 185: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 13: The import java.util.logging.Level is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 54: The field LwjglVectorFont.log is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 185: The type LwjglVectorFont.VectorCharData is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 193: The constructor LwjglVectorFont.VectorCharData(int[], float[][], float) is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 210: The method getAdvance() from the type LwjglVectorFont.VectorCharData is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 219: The method getType(int) from the type LwjglVectorFont.VectorCharData is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglVectorFont.java,> line 227: The method getVertices(int) from the type LwjglVectorFont.VectorCharData is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglFontManager.java,> line 50: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/font/LwjglFont.java,> line 58: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/Graphics3DLwjgl.java,> line 321: The field Graphics3DLwjgl.ATTRIB_MASK is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/Graphics3DLwjgl.java,> line 540: The local variable pos2d is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl/src/java/org/eclipse/draw3d/graphics3d/lwjgl/Graphics3DLwjgl.java,> line 676: The method generateVectorText(PrimitiveSet, List<RenderImage>) from the type Graphics3DLwjgl is never used locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.lwjgl>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.ui/src/org/eclipse/draw3d/ui/camera/CameraInputHandler.java,> line 63: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.draw3d.ui>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/dependencies/plugins/org.eclipse.emf.java>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 73: The import org.eclipse.emf.edit.provider.ReflectiveItemProviderAdapterFactory is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 83: The import org.eclipse.emf.edit.ui.provider.UnwrappingSelectionProvider is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 106: The import org.eclipse.jface.viewers.TableLayout is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 122: The import org.eclipse.swt.widgets.Table is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 123: The import org.eclipse.swt.widgets.TableColumn is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 147: The import org.eclipse.ui.views.properties.tabbed.TabbedPropertySheetPage is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 963: Map is a raw type. References to generic type Map<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 963: HashMap is a raw type. References to generic type HashMap<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 969: Map is a raw type. References to generic type Map<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 1280: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 1282: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 1450: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/MetaABMEditor.java,> line 1450: ArrayList is a raw type. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/CustomMetaABMModelWizard.java,> line 246: Map is a raw type. References to generic type Map<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/ide/CustomMetaABMModelWizard.java,> line 246: HashMap is a raw type. References to generic type HashMap<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/function/ide/MetaABMFunctionEditor.java,> line 1207: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/function/ide/MetaABMFunctionEditor.java,> line 1205: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/act/ide/MetaABMActEditor.java,> line 1205: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/src/org/metaabm/act/ide/MetaABMActEditor.java,> line 1207: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/plugin.xml,> line 68: The extension point 'org.eclipse.ui.editorActions' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/plugin.xml,> line 69: Element 'editorContribution' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.acore.editor/plugin.xml,> line 72: Element 'action' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/ui/parts/GraphicalViewer3DImpl.java,> line 124: Collection is a raw type. References to generic type Collection<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/ui/parts/GraphicalViewer3DImpl.java,> line 158: The local variable canvas is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/ui/parts/GraphicalViewer3DHelper.java,> line 180: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/ui/parts/GraphicalViewer3DHelper.java,> line 182: Collection is a raw type. References to generic type Collection<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/ui/parts/GraphicalViewer3DHelper.java,> line 66: Collection is a raw type. References to generic type Collection<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/ui/actions/Export3DAction.java,> line 23: The import org.eclipse.gef3d.ui.parts.GraphicalViewer3DImpl is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/tools/ToolInput.java,> line 22: The field ToolInput.m_verifyMouseButtons is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/tools/DragEditPartsTracker3D.java,> line 24: The import org.eclipse.draw3d.RenderContext is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/requests/ChangeBounds3DRequest.java,> line 13: The import java.util.logging.Level is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/requests/ChangeBounds3DRequest.java,> line 51: The field ChangeBounds3DRequest.log is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/handles/MoveHandle3D.java,> line 23: The import org.eclipse.draw3d.geometry.Math3D is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/handles/MoveHandle3D.java,> line 24: The import org.eclipse.draw3d.geometry.Math3DCache is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/handles/AbstractHandle3D.java,> line 48: The field AbstractHandle3D.log is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/XYZConstraintLayoutPolicy.java,> line 13: The import org.eclipse.draw2d.IFigure is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/XYZConstraintLayoutPolicy.java,> line 14: The import org.eclipse.draw2d.geometry.Rectangle is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/XYZConstraintLayoutPolicy.java,> line 18: The import org.eclipse.draw3d.geometry.IBoundingBox is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/RotatableEditPolicy3D.java,> line 32: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/ResizableEditPolicy3D.java,> line 153: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/NonResizableEditPolicy3D.java,> line 85: Unnecessary @SuppressWarnings("unchecked")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/NonResizableEditPolicy3D.java,> line 87: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/FeedbackHelper3D.java,> line 31: The import org.eclipse.draw3d.geometry.Matrix4fImpl is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/FeedbackHelper3D.java,> line 50: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/FeedbackHelper3D.java,> line 171: The local variable initialSurface is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/AbstractDecoratorEditPolicy.java,> line 92: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editpolicies/AbstractDecoratorEditPolicy.java,> line 93: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editparts/AbstractConnectionEditPartEx.java,> line 14: The import org.eclipse.gef.editparts.AbstractConnectionEditPart is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editparts/AbstractConnectionEditPart3D.java,> line 14: The import org.eclipse.draw2d.AnchorListener is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editparts/AbstractConnectionEditPart3D.java,> line 18: The import org.eclipse.draw2d.geometry.Point is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/src/java/org/eclipse/gef3d/editparts/AbstractConnectionEditPart3D.java,> line 20: The import org.eclipse.draw3d.geometry.IVector3f is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/buckminster.workspace/plugins/org.eclipse.gef3d/plugin.xml,> line 1: A plug-in manifest must contain at least one extension or extension point
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Shapes3D.java,> line 68: The field Shapes3D.HALF_SIZE is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/ScapeEditRoot3DPart.java,> line 89: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/ScapeEdit3DPart.java,> line 77: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Model3DAdapterFactory.java,> line 38: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Model3DAdapterFactory.java,> line 58: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/IGraphics3DAdapter.java,> line 44: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapterFactory.java,> line 20: The import org.eclipse.amp.axf.core.IModel is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapterFactory.java,> line 22: The import org.eclipse.core.runtime.Platform is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapterFactory.java,> line 32: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapterFactory.java,> line 52: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapter.java,> line 30: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapter.java,> line 48: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapter.java,> line 58: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/src/org/eclipse/amp/agf3d/Graphics3DAdapter.java,> line 79: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 17: The extension point 'org.eclipse.ui.viewActions' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 18: Element 'viewContribution' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 21: Element 'action' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 32: Element 'viewContribution' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 35: Element 'action' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 46: Element 'viewContribution' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 49: Element 'action' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 60: Element 'viewContribution' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.agf/plugins/org.eclipse.amp.agf3d/plugin.xml,> line 63: Element 'action' is deprecated
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ascape.agf3d/src/org/eclipse/amp/escape/ascape/adapt/AscapeDefaultGraphics3DAdapter.java,> line 42: Class is a raw type. References to generic type Class<T> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ascape.agf3d>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.runtime>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/ide/ProjectWizard.java,> line 111: Unnecessary @SuppressWarnings("unused")
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/ide/InfoView.java,> line 46: Discouraged access: The type BundleLoader is not accessible due to restriction on required library <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/target.platform/plugins/org.eclipse.osgi_3.8.0.v20110726-1606.jar>
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/ide/InfoView.java,> line 46: Discouraged access: The method findResource(String) from the type BundleLoader is not accessible due to restriction on required library <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/buildroot/target.platform/plugins/org.eclipse.osgi_3.8.0.v20110726-1606.jar>
Error: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/ide/ActionSetDisabler.java,> line 66: Perspective cannot be resolved to a type
Error: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/ide/ActionSetDisabler.java,> line 66: The method findPerspective(IPerspectiveDescriptor) is undefined for the type WorkbenchPage
Error: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/ide/ActionSetDisabler.java,> line 29: The import org.eclipse.ui.internal.Perspective cannot be resolved
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/src/org/eclipse/amp/escape/command/ExecuteHandler.java,> line 18: The import org.eclipse.amp.axf.time.TimeGranularity is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/plugin.xml,> line 236: Referenced identifier 'org.ascape.wizards.newProject' in attribute 'id' cannot be found
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/plugin.xml,> line 276: Referenced identifier 'org.eclipse.amp.view.GEFView:*' in attribute 'id' cannot be found
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/plugin.xml,> line 279: Referenced identifier 'org.eclipse.amp.view.GEF3DView:*' in attribute 'id' cannot be found
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/plugin.xml,> line 288: Referenced identifier 'org.eclipse.amp.escape.view.GraphicsView:*' in attribute 'id' cannot be found
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/build.properties,> line 12: The folder "schema/" does not exist in the workspace
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/build.properties,> line 15: The folder "schema/" does not exist in the workspace
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.ide/build.properties,> line 13: test/ is missing from source..
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/TestRunSet.java,> line 92: Map is a raw type. References to generic type Map<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/TestRunSet.java,> line 92: HashMap is a raw type. References to generic type HashMap<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/TestRunSet.java,> line 289: Map is a raw type. References to generic type Map<K,V> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/TestRunSet.java,> line 73: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/TestRunSet.java,> line 73: ArrayList is a raw type. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/TestRun.java,> line 95: The field TestRun.runSet is never read locally
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide/src/org/eclipse/amp/amf/testing/ide/ExecuteTestHandler.java,> line 57: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.testing.ide>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.ide.ascape>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.ide.ascape/build.properties,> line 8: The folder "res/" does not exist in the workspace
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/view/EMFDataOutputView.java,> line 47: The import org.eclipse.emf.ecore.resource.impl.ResourceFactoryImpl is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/view/EMFDataOutputView.java,> line 170: List is a raw type. References to generic type List<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/view/EMFDataOutputView.java,> line 171: Iterator is a raw type. References to generic type Iterator<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/amf/ide/ExecuteParamEMFOutputHandler.java,> line 19: The import org.eclipse.emf.ecore.resource.impl.ResourceFactoryImpl is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/amf/ide/ExecuteAMFEMFOutputHandler.java,> line 19: The import org.eclipse.amp.escape.view.EMFDataOutputView is never used
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/amf/ide/EclipseEMFOutputRunner.java,> line 40: ArrayList is a raw type. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/amf/ide/EclipseEMFOutputRunner.java,> line 40: ArrayList is a raw type. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/src/org/eclipse/amp/escape/amf/ide/EclipseEMFOutputRunner.java,> line 40: Type safety: The constructor ArrayList(Collection) belongs to the raw type ArrayList. References to generic type ArrayList<E> should be parameterized
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide/build.properties,> line 8: The folder "res/" does not exist in the workspace
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.escape/plugins/org.eclipse.amp.escape.amf.ide3d>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.axf/plugins/org.eclipse.amp.axf.sd/src/org/eclipse/amp/axf/sd/model/AbstractSDModel.java,> line 64: The local variable tmp is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.axf/plugins/org.eclipse.amp.axf.sd/src/org/eclipse/amp/axf/sd/model/AbstractSDModel.java,> line 70: The local variable tmp is never read
Warning: file <https://hudson.eclipse.org/hudson/job/amp-nightly/ws/org.eclipse.amp.git/org.eclipse.amp.amf/plugins/org.eclipse.amp.amf.sd.gen>: Build path specifies execution environment J2SE-1.5. There are no JREs installed in the workspace that are strictly compatible with this environment.
ERROR: SVN: 'Save Authorization Info' operation finished with error
 ERROR: SVN: 'Save Authorization Info' operation finished with error: No secure storage modules found.
org.eclipse.equinox.security.storage.StorageException: No secure storage modules found.
at org.eclipse.equinox.internal.security.storage.PasswordProviderSelector.findStorageModule(PasswordProviderSelector.java:190)
at org.eclipse.equinox.internal.security.storage.SecurePreferencesRoot.getModulePassword(SecurePreferencesRoot.java:231)
at org.eclipse.equinox.internal.security.storage.SecurePreferencesRoot.getPassword(SecurePreferencesRoot.java:224)
at org.eclipse.equinox.internal.security.storage.SecurePreferences.put(SecurePreferences.java:224)
at org.eclipse.equinox.internal.security.storage.SecurePreferencesWrapper.put(SecurePreferencesWrapper.java:110)
at org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.saveAuthInfo(AbstractSVNStorage.java:557)
at org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.saveLocations(AbstractSVNStorage.java:515)
at org.eclipse.team.svn.core.svnstorage.AbstractSVNStorage.saveConfiguration(AbstractSVNStorage.java:298)
at org.eclipse.team.svn.core.SVNTeamPlugin.stop(SVNTeamPlugin.java:190)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:843)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.framework.internal.core.BundleContextImpl.stop(BundleContextImpl.java:836)
at org.eclipse.osgi.framework.internal.core.BundleHost.stopWorker(BundleHost.java:501)
at org.eclipse.osgi.framework.internal.core.AbstractBundle.suspend(AbstractBundle.java:550)
at org.eclipse.osgi.framework.internal.core.Framework.suspendBundle(Framework.java:1097)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.decFWSL(StartLevelManager.java:597)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:257)
at org.eclipse.osgi.framework.internal.core.StartLevelManager.shutdown(StartLevelManager.java:215)
at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.suspend(InternalSystemBundle.java:266)
at org.eclipse.osgi.framework.internal.core.Framework.shutdown(Framework.java:690)
at org.eclipse.osgi.framework.internal.core.Framework.close(Framework.java:588)
at org.eclipse.core.runtime.adaptor.EclipseStarter.shutdown(EclipseStarter.java:415)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:198)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)
at org.eclipse.equinox.launcher.Main.run(Main.java:1408)
at org.eclipse.equinox.launcher.Main.main(Main.java:1384)
Terminating xvnc.
Archiving artifacts
Recording test results
Failed to send e-mail to Urs Frei because no e-mail address is known, and no default e-mail domain is configured