[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [eclipse-dev] Gerrit job fails for want of package javax.annotation

> What has changed between Monday and Wednesday (yesterday) that could have caused
> these bundles to be required for a headless test execution?

Did you verify that they were not loaded on Monday?

Dani



From:        Stephan Herrmann <stephan.herrmann@xxxxxxxxx>
To:        eclipse-dev@xxxxxxxxxxx, Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
Date:        26.04.2018 16:09
Subject:        Re: [eclipse-dev] Gerrit job fails for want of package javax.annotation
Sent by:        eclipse-dev-bounces@xxxxxxxxxxx




At a closer look, none of the dependencies that causes the failure should
ever be touched by this test execution.
Tycho correctly invokes org.eclipse.tycho.surefire.osgibooter.headlesstest
and our test plug-in has none of this in its dependencies.

This is the list of bogusly required bundles:
org.eclipse.compare
org.eclipse.ui
org.eclipse.ui.ide
org.eclipse.ui.workbench.texteditor
org.eclipse.ui.editors
org.eclipse.e4.core.di
org.eclipse.e4.core.contexts
org.eclipse.e4.core.services
org.eclipse.e4.core.di.extensions.supplier
org.eclipse.e4.ui.bindings
org.eclipse.e4.ui.di
org.eclipse.e4.ui.model.workbench
org.eclipse.e4.ui.services
org.eclipse.e4.ui.workbench
org.eclipse.e4.ui.workbench.renderers.swt
org.eclipse.e4.ui.workbench.swt
org.eclipse.e4.ui.workbench.addons.swt
org.eclipse.ui.navigator
org.eclipse.team.ui
org.eclipse.ltk.ui.refactoring
org.eclipse.ui.ide.application

What has changed between Monday and Wednesday (yesterday) that could have caused
these bundles to be required for a headless test execution?

Stephan

On 25.04.2018 23:43, Stephan Herrmann wrote:
> Hi,
>
> JDT's gerrit job fails since
https://urldefense.proofpoint.com/v2/url?u=https-3A__ci.eclipse.org_jdt_job_eclipse.jdt.core-2DGerrit_801&d=DwIGaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=pl8M9hs9ylPAXzVa_zR7kYbTGzLsVwOFoV1rb05KPA0&s=NREHb8uNA6rvND4g0Wg0NNI1hUZvQtd0SDMBqm2Sf0Q&e=
> the console message being:
>
> 16:28:44 [ERROR] Failed to execute goal org.eclipse.tycho:tycho-surefire-plugin:1.2.0-SNAPSHOT:test (default-test) on project
> org.eclipse.jdt.core.tests.compiler: An unexpected error occured while launching the test runtime (return code 13). See log for
> details. -> [Help 1]
>
> Checking the log file I see lots of references to missing package javax.annotation
> reproduced below.
>
> To check that this is really the issue I added "--add-modules ALL-SYSTEM" to
> tycho-surefire's argLine, and indeed the given test plugin can now be launched (#803).
> Obviously such pom-change is bogus, as it would tie the build to Java 9.
>
> More importantly, does anyone know a very recent change that could have produced this problem?
>
> best
> Stephan
>
> --------------8<--------------------
>
> !SESSION 2018-04-25 16:28:41.759 -----------------------------------------------
> eclipse.buildId=unknown
> java.version=9
> java.vendor=Oracle Corporation
> BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
> Framework arguments:  -application org.eclipse.tycho.surefire.osgibooter.headlesstest -testproperties
> /jobs/genie.jdt/eclipse.jdt.core-Gerrit/workspace/org.eclipse.jdt.core.tests.compiler/target/surefire.properties
> Command-line arguments:  -data
> /jobs/genie.jdt/eclipse.jdt.core-Gerrit/workspace/org.eclipse.jdt.core.tests.compiler/target/work/data -application
> org.eclipse.tycho.surefire.osgibooter.headlesstest -testproperties
> /jobs/genie.jdt/eclipse.jdt.core-Gerrit/workspace/org.eclipse.jdt.core.tests.compiler/target/surefire.properties
>
> !ENTRY org.eclipse.compare 4 0 2018-04-25 16:28:42.713
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.compare [14]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui.views [19]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>         org.eclipse.ui.workbench.texteditor [20]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>         org.eclipse.ui.editors [23]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                org.eclipse.ui.ide [18]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui 4 0 2018-04-25 16:28:42.715
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui [15]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>         org.eclipse.ui.workbench [98]
>           Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.ide 4 0 2018-04-25 16:28:42.715
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.ide [18]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.workbench.texteditor 4 0 2018-04-25 16:28:42.716
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench.texteditor [20]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.editors 4 0 2018-04-25 16:28:42.716
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.editors [23]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>         org.eclipse.ui.ide [18]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.10.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>         org.eclipse.ui.workbench.texteditor [20]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.core.di 4 0 2018-04-25 16:28:42.716
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.core.di [45]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.core.contexts 4 0 2018-04-25 16:28:42.717
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.core.contexts [47]
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>      -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>         org.eclipse.e4.core.di [45]
>           Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.core.services 4 0 2018-04-25 16:28:42.717
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.core.services [48]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.core.di.extensions.supplier 4 0 2018-04-25 16:28:42.717
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.core.di.extensions.supplier [51]
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts; version="1.6.0"
>      -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts";
> bundle-version="1.7.0.v20180424-1120"; version="1.7.0"
>         org.eclipse.e4.core.contexts [47]
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>             -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>                org.eclipse.e4.core.di [45]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.di
>      -> Export-Package: org.eclipse.e4.core.di; bundle-symbolic-name="org.eclipse.e4.core.di";
> bundle-version="1.7.0.v20180403-1008"; version="1.7.0"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.bindings 4 0 2018-04-25 16:28:42.718
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.bindings [58]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.di 4 0 2018-04-25 16:28:42.736
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.di [62]
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts; version="1.6.0"
>      -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts";
> bundle-version="1.7.0.v20180424-1120"; version="1.7.0"
>         org.eclipse.e4.core.contexts [47]
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>             -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>                org.eclipse.e4.core.di [45]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.di.internal.extensions; version="0.15.0"
>      -> Export-Package: org.eclipse.e4.core.di.internal.extensions;
> bundle-symbolic-name="org.eclipse.e4.core.di.extensions.supplier"; bundle-version="0.15.100.v20180411-1920"; version="0.15.0";
> x-friends:="org.eclipse.e4.ui.di"
>         org.eclipse.e4.core.di.extensions.supplier [51]
>           Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts; version="1.6.0"
>             -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts";
> bundle-version="1.7.0.v20180424-1120"; version="1.7.0"
>           Unresolved requirement: Import-Package: org.eclipse.e4.core.di
>             -> Export-Package: org.eclipse.e4.core.di; bundle-symbolic-name="org.eclipse.e4.core.di";
> bundle-version="1.7.0.v20180403-1008"; version="1.7.0"
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.di.suppliers
>      -> Export-Package: org.eclipse.e4.core.di.suppliers; bundle-symbolic-name="org.eclipse.e4.core.di";
> bundle-version="1.7.0.v20180403-1008"; version="1.7.0"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.model.workbench 4 0 2018-04-25 16:28:42.738
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.model.workbench [63]
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.contexts; bundle-version="1.0.0"
>      -> Bundle-SymbolicName: org.eclipse.e4.core.contexts; bundle-version="1.7.0.v20180424-1120"
>         org.eclipse.e4.core.contexts [47]
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>             -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>                org.eclipse.e4.core.di [45]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="1.0.0"
>      -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
>      -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.1.100.v20180417-1347"; singleton:="true"
>         org.eclipse.e4.core.services [48]
>           Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.services 4 0 2018-04-25 16:28:42.739
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.services [64]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.workbench 4 0 2018-04-25 16:28:42.742
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench [69]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.workbench.renderers.swt 4 0 2018-04-25 16:28:42.743
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt [70]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.workbench.swt 4 0 2018-04-25 16:28:42.744
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.swt [71]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.e4.ui.workbench.addons.swt 4 0 2018-04-25 16:28:42.744
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.e4.ui.workbench.addons.swt [72]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.navigator 4 0 2018-04-25 16:28:42.755
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.navigator [93]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.team.ui 4 0 2018-04-25 16:28:42.757
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.team.ui [95]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>         org.eclipse.ui.editors [23]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                org.eclipse.ui.ide [18]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                       org.eclipse.ui [15]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                              org.eclipse.ui.workbench [98]
>                                Unresolved requirement: Import-Package: javax.annotation
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"; resolution:="optional"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>         org.eclipse.compare [14]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>         org.eclipse.ui.navigator [93]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ltk.ui.refactoring 4 0 2018-04-25 16:28:42.761
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ltk.ui.refactoring [96]
>    Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>         org.eclipse.compare [14]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui.views [19]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                       org.eclipse.ui [15]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                              org.eclipse.ui.workbench [98]
>                                Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>                org.eclipse.ui.workbench.texteditor [20]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>                org.eclipse.ui.editors [23]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                       org.eclipse.ui.ide [18]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.team.ui; bundle-version="[3.4.100,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.team.ui; bundle-version="3.8.100.v20180418-1233"; singleton:="true"
>         org.eclipse.team.ui [95]
>           Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>                org.eclipse.ui.navigator [93]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"; resolution:="optional"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.200,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.workbench 4 0 2018-04-25 16:28:42.762
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.workbench [98]
>    Unresolved requirement: Import-Package: javax.annotation
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.ide.application 4 0 2018-04-25 16:28:42.764
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.ide.application [99]
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.model.workbench
>      -> Bundle-SymbolicName: org.eclipse.e4.ui.model.workbench; bundle-version="2.1.0.v20180403-0945"; singleton:="true"
>         org.eclipse.e4.ui.model.workbench [63]
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.contexts; bundle-version="1.0.0"
>             -> Bundle-SymbolicName: org.eclipse.e4.core.contexts; bundle-version="1.7.0.v20180424-1120"
>                org.eclipse.e4.core.contexts [47]
>                  Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>                    -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>                       org.eclipse.e4.core.di [45]
>                         Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di; bundle-version="1.0.0"
>             -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"

>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
>             -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.1.100.v20180417-1347"; singleton:="true"
>                org.eclipse.e4.core.services [48]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.ui.workbench
>      -> Bundle-SymbolicName: org.eclipse.e4.ui.workbench; bundle-version="1.6.0.v20180424-1922"; singleton:="true"
>         org.eclipse.e4.ui.workbench [69]
>           Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator.resources; bundle-version="[3.4.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.navigator.resources; bundle-version="3.6.100.v20180420-1611"; singleton:="true"
>         org.eclipse.ui.navigator.resources [100]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                org.eclipse.ui.ide [18]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                       org.eclipse.ui [15]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                              org.eclipse.ui.workbench [98]
>                                Unresolved requirement: Import-Package: javax.annotation
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>      -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.navigator.resources 4 0 2018-04-25 16:28:42.767
> !MESSAGE FrameworkEvent ERROR
> !STACK 0
> org.osgi.framework.BundleException: Could not resolve module: org.eclipse.ui.navigator.resources [100]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>         org.eclipse.ui.ide [18]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ltk.ui.refactoring; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ltk.ui.refactoring; bundle-version="3.9.100.v20180425-1219"; singleton:="true"
>         org.eclipse.ltk.ui.refactoring [96]
>           Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>                org.eclipse.compare [14]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.team.ui; bundle-version="[3.4.100,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.team.ui; bundle-version="3.8.100.v20180418-1233"; singleton:="true"
>                org.eclipse.team.ui [95]
>                  Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.3.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"; resolution:="optional"
>                    -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.200,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>                org.eclipse.ui.navigator [93]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>         org.eclipse.ui.workbench.texteditor [20]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.views.properties.tabbed; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.views.properties.tabbed; bundle-version="3.8.100.v20180418-0844"; singleton:="true"
>         org.eclipse.ui.views.properties.tabbed [101]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.3.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui.views [19]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>
>      at org.eclipse.osgi.container.Module.start(Module.java:444)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1682)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1661)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1624)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1555)
>      at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
>      at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
>      at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
>
> !ENTRY org.eclipse.ui.editors 2 0 2018-04-25 16:28:43.159
> !MESSAGE Could not resolve module: org.eclipse.ui.editors [23]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>         org.eclipse.ui.ide [18]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>
>
> !ENTRY org.eclipse.ui.workbench 2 0 2018-04-25 16:28:43.159
> !MESSAGE Could not resolve module: org.eclipse.ui.workbench [98]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.core.services 2 0 2018-04-25 16:28:43.159
> !MESSAGE Could not resolve module: org.eclipse.e4.core.services [48]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.ui.workbench.renderers.swt 2 0 2018-04-25 16:28:43.160
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.renderers.swt [70]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.ui 2 0 2018-04-25 16:28:43.160
> !MESSAGE Could not resolve module: org.eclipse.ui [15]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>         org.eclipse.ui.workbench [98]
>           Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.ui.navigator 2 0 2018-04-25 16:28:43.160
> !MESSAGE Could not resolve module: org.eclipse.ui.navigator [93]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.ui.bindings 2 0 2018-04-25 16:28:43.160
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.bindings [58]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.ui.views 2 0 2018-04-25 16:28:43.161
> !MESSAGE Could not resolve module: org.eclipse.ui.views [19]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.swt.gtk.linux.ppc64le 2 0 2018-04-25 16:28:43.161
> !MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc64le [107]
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64le))"
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64le))"
>
>
> !ENTRY org.eclipse.swt.gtk.linux.x86 2 0 2018-04-25 16:28:43.161
> !MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.x86 [97]
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=x86))"
>
>
> !ENTRY org.eclipse.e4.core.di.extensions.supplier 2 0 2018-04-25 16:28:43.161
> !MESSAGE Could not resolve module: org.eclipse.e4.core.di.extensions.supplier [51]
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts; version="1.6.0"
>      -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts";
> bundle-version="1.7.0.v20180424-1120"; version="1.7.0"
>         org.eclipse.e4.core.contexts [47]
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>             -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>                org.eclipse.e4.core.di [45]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.ui.workbench 2 0 2018-04-25 16:28:43.162
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench [69]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.swt.win32.win32.x86_64 2 0 2018-04-25 16:28:43.162
> !MESSAGE Could not resolve module: org.eclipse.swt.win32.win32.x86_64 [109]
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86_64))"
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86_64))"
>
>
> !ENTRY org.eclipse.ui.ide 2 0 2018-04-25 16:28:43.162
> !MESSAGE Could not resolve module: org.eclipse.ui.ide [18]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>
>
> !ENTRY org.eclipse.e4.ui.di 2 0 2018-04-25 16:28:43.162
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.di [62]
>    Unresolved requirement: Import-Package: org.eclipse.e4.core.contexts; version="1.6.0"
>      -> Export-Package: org.eclipse.e4.core.contexts; bundle-symbolic-name="org.eclipse.e4.core.contexts";
> bundle-version="1.7.0.v20180424-1120"; version="1.7.0"
>         org.eclipse.e4.core.contexts [47]
>           Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>             -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>                org.eclipse.e4.core.di [45]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.ui.model.workbench 2 0 2018-04-25 16:28:43.163
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.model.workbench [63]
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.services; bundle-version="0.9.0"
>      -> Bundle-SymbolicName: org.eclipse.e4.core.services; bundle-version="2.1.100.v20180417-1347"; singleton:="true"
>         org.eclipse.e4.core.services [48]
>           Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.core.commands 2 0 2018-04-25 16:28:43.163
> !MESSAGE Could not resolve module: org.eclipse.e4.core.commands [44]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.ltk.ui.refactoring 2 0 2018-04-25 16:28:43.164
> !MESSAGE Could not resolve module: org.eclipse.ltk.ui.refactoring [96]
>    Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>         org.eclipse.compare [14]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui.views [19]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                       org.eclipse.ui [15]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                              org.eclipse.ui.workbench [98]
>                                Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>                org.eclipse.ui.workbench.texteditor [20]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>                org.eclipse.ui.editors [23]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                       org.eclipse.ui.ide [18]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.team.ui; bundle-version="[3.4.100,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.team.ui; bundle-version="3.8.100.v20180418-1233"; singleton:="true"
>         org.eclipse.team.ui [95]
>           Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>                org.eclipse.ui.navigator [93]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"; resolution:="optional"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.200,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>
>
> !ENTRY org.eclipse.compare 2 0 2018-04-25 16:28:43.164
> !MESSAGE Could not resolve module: org.eclipse.compare [14]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui.views [19]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>         org.eclipse.ui.workbench.texteditor [20]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>         org.eclipse.ui.editors [23]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                org.eclipse.ui.ide [18]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>
>
> !ENTRY org.eclipse.ui.views.properties.tabbed 2 0 2018-04-25 16:28:43.165
> !MESSAGE Could not resolve module: org.eclipse.ui.views.properties.tabbed [101]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.3.0,4.0.0)"; visibility:="reexport"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"; visibility:="reexport"
>      -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui.views [19]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>
>
> !ENTRY org.eclipse.e4.ui.services 2 0 2018-04-25 16:28:43.165
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.services [64]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.ui.ide.application 2 0 2018-04-25 16:28:43.165
> !MESSAGE Could not resolve module: org.eclipse.ui.ide.application [99]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>         org.eclipse.ui.ide [18]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>
>
> !ENTRY org.eclipse.ui.navigator.resources 2 0 2018-04-25 16:28:43.165
> !MESSAGE Could not resolve module: org.eclipse.ui.navigator.resources [100]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.6.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>         org.eclipse.ui.ide [18]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui [15]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                    -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                       org.eclipse.ui.workbench [98]
>                         Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>
>
> !ENTRY org.eclipse.team.ui 2 0 2018-04-25 16:28:43.166
> !MESSAGE Could not resolve module: org.eclipse.team.ui [95]
>    Unresolved requirement: Require-Bundle: org.eclipse.compare; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.compare; bundle-version="3.7.200.v20180418-1233"; singleton:="true"
>         org.eclipse.compare [14]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.views; bundle-version="[3.2.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.views; bundle-version="3.9.100.v20180403-0945"; singleton:="true"
>                org.eclipse.ui.views [19]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                       org.eclipse.ui [15]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)";
> visibility:="reexport"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                              org.eclipse.ui.workbench [98]
>                                Unresolved requirement: Import-Package: javax.annotation
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench.texteditor; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench.texteditor; bundle-version="3.11.0.v20180419-2011"; singleton:="true"
>                org.eclipse.ui.workbench.texteditor [20]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.5.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>                org.eclipse.ui.editors [23]
>                  Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.5.0,4.0.0)"
>                    -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>                       org.eclipse.ui.ide [18]
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.106.0,4.0.0)"
>                           -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>                         Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.7.0,4.0.0)"
>                           -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.navigator; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.navigator; bundle-version="3.7.100.v20180418-0844"; singleton:="true"
>         org.eclipse.ui.navigator [93]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.6.0,4.0.0)"
>             -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.editors; bundle-version="[3.3.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui.editors; bundle-version="3.11.100.v20180419-1904"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>    Unresolved requirement: Require-Bundle: org.eclipse.ui.ide; bundle-version="[3.3.0,4.0.0)"; resolution:="optional"
>      -> Bundle-SymbolicName: org.eclipse.ui.ide; bundle-version="3.14.0.v20180423-1554"; singleton:="true"
>
>
> !ENTRY org.eclipse.e4.core.contexts 2 0 2018-04-25 16:28:43.166
> !MESSAGE Could not resolve module: org.eclipse.e4.core.contexts [47]
>    Unresolved requirement: Require-Bundle: org.eclipse.e4.core.di
>      -> Bundle-SymbolicName: org.eclipse.e4.core.di; bundle-version="1.7.0.v20180403-1008"
>         org.eclipse.e4.core.di [45]
>           Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.swt.gtk.linux.ppc64 2 0 2018-04-25 16:28:43.167
> !MESSAGE Could not resolve module: org.eclipse.swt.gtk.linux.ppc64 [106]
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=gtk) (osgi.os=linux) (osgi.arch=ppc64))"
>
>
> !ENTRY org.eclipse.e4.ui.workbench.addons.swt 2 0 2018-04-25 16:28:43.167
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.addons.swt [72]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.ui.workbench.texteditor 2 0 2018-04-25 16:28:43.167
> !MESSAGE Could not resolve module: org.eclipse.ui.workbench.texteditor [20]
>    Unresolved requirement: Require-Bundle: org.eclipse.ui; bundle-version="[3.5.0,4.0.0)"
>      -> Bundle-SymbolicName: org.eclipse.ui; bundle-version="3.109.100.v20180403-0945"; singleton:="true"
>         org.eclipse.ui [15]
>           Unresolved requirement: Require-Bundle: org.eclipse.ui.workbench; bundle-version="[3.105.0,4.0.0)"; visibility:="reexport"
>             -> Bundle-SymbolicName: org.eclipse.ui.workbench; bundle-version="3.111.0.v20180420-1055"; singleton:="true"
>                org.eclipse.ui.workbench [98]
>                  Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.e4.ui.workbench.swt 2 0 2018-04-25 16:28:43.167
> !MESSAGE Could not resolve module: org.eclipse.e4.ui.workbench.swt [71]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.tycho.surefire.junit4 2 0 2018-04-25 16:28:43.167
> !MESSAGE Could not resolve module: org.eclipse.tycho.surefire.junit4 [112]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.swt.win32.win32.x86 2 0 2018-04-25 16:28:43.168
> !MESSAGE Could not resolve module: org.eclipse.swt.win32.win32.x86 [108]
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=win32) (osgi.os=win32) (osgi.arch=x86))"
>
>
> !ENTRY org.eclipse.e4.core.di 2 0 2018-04-25 16:28:43.168
> !MESSAGE Could not resolve module: org.eclipse.e4.core.di [45]
>    Unresolved requirement: Import-Package: javax.annotation
>
>
> !ENTRY org.eclipse.swt.cocoa.macosx.x86_64 2 0 2018-04-25 16:28:43.169
> !MESSAGE Could not resolve module: org.eclipse.swt.cocoa.macosx.x86_64 [110]
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"
>    Unresolved requirement: Require-Capability: eclipse.platform; filter:="(& (osgi.ws=cocoa) (osgi.os=macosx) (osgi.arch=x86_64) )"
>
>
> !ENTRY org.eclipse.osgi 4 0 2018-04-25 16:28:43.169
> !MESSAGE Application error
> !STACK 1
> org.apache.maven.surefire.util.SurefireReflectionException: java.lang.ClassNotFoundException:
> org.apache.maven.surefire.junit4.JUnit4Provider
>      at org.apache.maven.surefire.util.ReflectionUtils.loadClass(ReflectionUtils.java:245)
>      at org.apache.maven.surefire.util.ReflectionUtils.instantiateOneArg(ReflectionUtils.java:129)
>      at org.apache.maven.surefire.booter.SurefireReflector.instantiateProvider(SurefireReflector.java:276)
>      at org.apache.maven.surefire.booter.ProviderFactory.createProvider(ProviderFactory.java:113)
>      at org.apache.maven.surefire.booter.ProviderFactory.invokeProvider(ProviderFactory.java:81)
>      at org.eclipse.tycho.surefire.osgibooter.OsgiSurefireBooter.run(OsgiSurefireBooter.java:107)
>      at org.eclipse.tycho.surefire.osgibooter.HeadlessTestApplication.run(HeadlessTestApplication.java:21)
>      at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>      at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
>      at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>      at java.base/java.lang.reflect.Method.invoke(Method.java:564)
>      at org.eclipse.equinox.internal.app.EclipseAppContainer.callMethodWithException(EclipseAppContainer.java:587)
>      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:198)
>      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
>      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
>      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
>      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
>      at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>      at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
>      at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>      at java.base/java.lang.reflect.Method.invoke(Method.java:564)
>      at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:656)
>      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:592)
>      at org.eclipse.equinox.launcher.Main.run(Main.java:1498)
>      at org.eclipse.equinox.launcher.Main.main(Main.java:1471)
> Caused by: java.lang.ClassNotFoundException: org.apache.maven.surefire.junit4.JUnit4Provider
>      at org.eclipse.tycho.surefire.osgibooter.CombinedClassLoader.findClass(CombinedClassLoader.java:37)
>      at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:563)
>      at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
>      at org.apache.maven.surefire.util.ReflectionUtils.loadClass(ReflectionUtils.java:237)
>      ... 24 more
> _______________________________________________
> eclipse-dev mailing list
> eclipse-dev@xxxxxxxxxxx
> To change your delivery options, retrieve your password, or unsubscribe from this list, visit
>
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_eclipse-2Ddev&d=DwIGaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=pl8M9hs9ylPAXzVa_zR7kYbTGzLsVwOFoV1rb05KPA0&s=hBl0mR_5-FPl_gjzRLrhtQbzSB3vA_9ZZmiUataaeqc&e=

_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://urldefense.proofpoint.com/v2/url?u=https-3A__dev.eclipse.org_mailman_listinfo_eclipse-2Ddev&d=DwIGaQ&c=jf_iaSHvJObTbx-siA1ZOg&r=1UITCR5rxUZHSFczvfaNFK4ymEbEiccRX7VKchpqz0Y&m=pl8M9hs9ylPAXzVa_zR7kYbTGzLsVwOFoV1rb05KPA0&s=hBl0mR_5-FPl_gjzRLrhtQbzSB3vA_9ZZmiUataaeqc&e=