[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Equinox Framework moving up to Java 7

Equinox is used in many environments where there is very long-term support for older Java levels.  So far I have needed to keep the Equinox Framework at a Java 6 level to be able to use the latest versions in these environments.

Unfortunately Java 6 is getting harder and harder to support while also accommodating new "hurdles" being presented with Java 9 [1].  I will be updating the Equinox Framework to Java 7 for Oxygen [2].  Please voice any concerns you may have in the bug report [2].  Although I expect very little concern since most have already moved onto Java 8!

Tom

[1]
https://bugs.eclipse.org/bugs/show_bug.cgi?id=502204
[2] https://bugs.eclipse.org/bugs/show_bug.cgi?id=502425