[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] little help with http.servlet.tests

Hello everyone,

I've just noted that for some very strange reason the tests in rt.equinox.bundles/bundles/org.eclipse.equinox.http.servlet.tests fail from the command line when run through maven:

mvn clean integration-test -DskipTests =false

It's failing to locate commons-fileupload:

[ERROR] Cannot resolve project dependencies: [ERROR] Software being installed: org.eclipse.equinox.http.servlet.tests 1.0.100.qualifier [ERROR] Missing requirement: org.eclipse.equinox.http.servlet.tests 1.0.100.qualifier requires 'package org.apache.commons.fileupload 1.2.2' but it could not be found

.. even though it's definitely in the resolved p2 repos.

The resolved repos are:

[INFO] Adding repository http://download.eclipse.org/tools/orbit/downloads/drops/I20160209143415/repository [INFO] Adding repository http://download.eclipse.org/modeling/emf/emf/updates/2.12milestones/base/S201601280808 [INFO] Adding repository http://download.eclipse.org/jetty/updates/jetty-bundles-9.x/9.3.5.v20151012 [INFO] Adding repository http://download.eclipse.org/rt/ecf/3.12.0/site.p2 [INFO] Adding repository http://download.eclipse.org/cbi/updates/license/1.0.1.v20140414-1359 [INFO] Adding repository http://download.eclipse.org/egit/updates-4.1 [INFO] Adding repository http://download.eclipse.org/modeling/emf/emf/updates/2.12milestones/core/S201511090426
--
Raymond AugÃÂ(@rotty3000)
Senior Software ArchitectÂLiferay, Inc.Â(@Liferay)
Board Member & EEG Co-Chair, OSGi Alliance (@OSGiAlliance)