[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [eclipse-dev] WAIT! Eclipse 4.5 RC2 and Equinox (Mars RC2) is NOT available for download -- WITHDRAWN

Apologies, but we are "withdrawing" this version of RC2 and will reconsider the changes that lead to the Bug 468061.
After some little more investigation its feared this issues may be more complex than we first thought and
want to "take the weekend" to reconsider. If we do end up fixing/reverting, it may minimize churn if users do not already have
this version of RC2 installed. If you have already installed it there's nothing you have to do now, but once we get RC2a ready,
we'll be sure to test, and document, if there is anything special you need to do to revert or .. if we are all lucky ... maybe it will be transparent.

Apologies again. We will have an update  on the situation by Sunday or Monday.





From:        David M Williams/Raleigh/IBM@IBMUS
To:        "General development mailing list of the Eclipse project." <eclipse-dev@xxxxxxxxxxx>, "Equinox development mailing list" <equinox-dev@xxxxxxxxxxx>,
Date:        05/22/2015 05:01 PM
Subject:        [eclipse-dev] Eclipse 4.5 RC2 and Equinox (Mars RC2) is available        for download
Sent by:        eclipse-dev-bounces@xxxxxxxxxxx




It is my pleasure to announce that "Mars RC2" is available from the Eclipse Platform Project.
But, see "UPDATE CAUTIONS" below, if you have an "old" version of a Mars installation (such as M6 or earlier).


Much thanks to everyone who made this release candidate possible.


       Eclipse downloads:

       
http://download.eclipse.org/eclipse/downloads/drops4/S-4.5RC2-201505211715/

       Update existing (non-production) installs:

       
http://download.eclipse.org/eclipse/updates/4.5milestones/

       Specific repository good for building against:

       
http://download.eclipse.org/eclipse/updates/4.5milestones/S-4.5RC2-201505211715/

       Equinox specific downloads:

       
http://download.eclipse.org/equinox/drops/S-MarsRC2-201505211715/

UPDATE CAUTIONS:
If you have a an installation of Mars from prior to 4/27 (such as M6), then you can not update directly to RC2.
You'll get a message about "blockMacUpdates action not found" and be left with a fragile, if not broken installation. (See
Bug 468061).

This does not apply to M7 or RC1 installations (nor Luna installations) ... those can all update directly to RC2.
But for earlier Mars installations, we recommend you either download a fresh copy of an archived install, or, you
update to M7 [1] or RC1 [2] first, before trying to update to RC2.


[1]
http://download.eclipse.org/eclipse/updates/4.5milestones/S-4.5M7-201504301445/
p2]
http://download.eclipse.org/eclipse/updates/4.5milestones/S-4.5RC1-201505141000/
_______________________________________________
eclipse-dev mailing list
eclipse-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/eclipse-dev