[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Eclipse won't work on > JDK9b61 unless default classloader hiearchy is changed

Hi,

On 05.05.15 16:05, Thomas Watson wrote:
> Please open a bug to track the issues.  I assume you are having to set
> the configuration property osgi.frameworkParentClassloader=ext to get
> this to work on Java 9?

Yes

> 
> I still believe the default 'parent' class loader for bundles should be
> 'boot', but the class loader used to load up the framework a therefore
> allow the framework to export the packages from ext can probably change.
> 

Why should it be boot? Even in Java8 this causes troubles and eg one can
not use Nashorn because its security checks are violated so one has to
launch with ext as the classloader hierarchy.

Felix for example does use the extension classloader as the default and
that's what a default java developer would expect as well (ok well he
would expect the app-classloader but he is not writing applications but
bundles I think ext would be the expected classloader at least)

Tom


-- 
Thomas Schindl, CTO
BestSolution.at EDV Systemhaus GmbH
Eduard-Bodem-Gasse 5-7, A-6020 Innsbruck
http://www.bestsolution.at/
Reg. Nr. FN 222302s am Firmenbuchgericht Innsbruck