[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] tycho-surefire tests

have you chased the chain of parent poms looking for a
definition of property skipTest *and/or* maven.test.skip?

Stephan

On 04/22/2015 07:06 PM, Raymond Auge wrote:
Does anyone here know how to make these tests work?

I can't for the life of me figure out how to get these tests to run for org.eclipse.equinox.http.servlet.tests

I've added a pom.xml (since there wasn't one)

<project xmlns="http://maven.apache.org/POM/4.0.0"; xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance";
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd";>
   <modelVersion>4.0.0</modelVersion>
   <parent>
     <artifactId>rt.equinox.bundles</artifactId>
     <groupId>org.eclipse.equinox.bundles</groupId>
     <version>4.5.0-SNAPSHOT</version>
     <relativePath>../../</relativePath>
   </parent>
   <groupId>org.eclipse.equinox</groupId>
   <artifactId>org.eclipse.equinox.http.servlet.tests</artifactId>
   <version>1.0.0-SNAPSHOT</version>
   <packaging>eclipse-test-plugin</packaging>
</project>

Didn't work!

I've read all the tycho-surefire docs/tutorials I could find but I can't seem to make things work.

I just keep getting

[INFO] Skipping tests
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS

Little help!
--
*Raymond Augé* <http://www.liferay.com/web/raymond.auge/profile> (@rotty3000)
Senior Software Architect *Liferay, Inc.* <http://www.liferay.com> (@Liferay)
Board Member & EEG Co-Chair, OSGi Alliance <http://osgi.org> (@OSGiAlliance)


_______________________________________________ equinox-dev mailing list equinox-dev@xxxxxxxxxxx To change your delivery options, retrieve your password, or unsubscribe from this list, visit https://dev.eclipse.org/mailman/listinfo/equinox-dev