[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Require-Capability and resolution directive doubts

Hi, just to clarify. I did two clean projects and I couldn't reproduce the problem in Equinox. It is checking the capabilities properly.

The unique thing that I reproduced was the message error thrown by PDE launcher that are not handling the resolution:=optional. will open a bug for it soon.

Then in order to resolve the problem in my real project I created a new workspace, set up a new target definition and re-imported maven projects again. I think it could be related to manifest generation and cache...

thanks anyway. regards,

Cristiano


2015-01-05 16:23 GMT-03:00 Cristiano GaviÃo <cvgaviao@xxxxxxxxx>:
Hi Thomas,
yep, not even resolving, the bundle with the requirement is being activated even with a mandatory capability no being resolved.
will prepare a small project that reproduce the scenario.
Cristiano

2015-01-05 14:03 GMT-03:00 Thomas Watson <tjwatson@xxxxxxxxxx>:

I'm not sure I understand the scenario. ÂAre you stating that even with a mandatory required capability the bundle is resolving at runtime?

Tom





From: Â Â Â ÂCristiano GaviÃo <cvgaviao@xxxxxxxxx>
To: Â Â Â ÂEquinox <equinox-dev@xxxxxxxxxxx>
Date: Â Â Â Â01/05/2015 09:21 AM
Subject: Â Â Â Â[equinox-dev] Require-Capability and resolution directive doubts
Sent by: Â Â Â Âequinox-dev-bounces@xxxxxxxxxxx




Hello all,
I'm facing a problem and would like some orientation in order to figure out if it is bug or new feature and the right component that is responsible. I'm using Juno and it equinox launcher.
So, I've set the capability below in one bundle manifest:

Require-Capability: manager;filter:="(&(area=provisioning)(vendor=*))",osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.7))"

The I configured a launcher properly and selected some few bundles. When I tried to run, PDE's launcher validation did a good job identifying that any bundle providing such capability was selected.
But what I noted is that if I let the equinox launcher run without worry about the warnings then the bundle that PDE was complaining before is in active state. It is active even with a missing requirement.
Question, which state that bundle should be then: installed ?

The I tried with a resolution directive (with or without quotes, because the manifest tool accepts both)

Require-Capability: manager;filter:="(&(area=provisioning)(vendor=*))";resolution:=optional,osgi.ee;filter:="(&(osgi.ee=JavaSE)(version=1.7))"

But PDE's launcher validation is still complaining about the missing capability.

It this a bug or a non implemented yet feature ?

thanks,

Cristiano_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev



--
"Tudo vale a pena se a alma nÃo à pequena..."



--
"Tudo vale a pena se a alma nÃo à pequena..."