[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] qualifiers in the tycho build

cross-posting to tycho-user

see general discussion https://bugs.eclipse.org/bugs/show_bug.cgi?id=440157#c5 .

One thing you can do however is to configure the "qualifier" (4th digit) replacement during build, see

https://wiki.eclipse.org/Tycho/FAQ#How_do_I_embed_a_configurable_build_version.3F 

e.g. in your example

<plugin>
  <groupId>org.eclipse.tycho</groupId>
  <artifactId>tycho-packaging-plugin</artifactId>
  <version>${tycho-version}</version>
  <configuration>
    <format>'b1-'yyyyMMddHHmm</format>
  </configuration>
</plugin>

Regards,
Jan


From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Raymond Auge
Sent: Montag, 22. September 2014 16:24
To: Equinox development mailing list
Subject: [equinox-dev] qualifiers in the tycho build

Is it possible to use a qualifier like:

b1-SNAPSHOP

i.e.

1.2.0.b1-SNAPSHOT //osgi syntax

OR

1.2.0-b1-SNAPSHOT //mvn syntax

When I change to either format the build invariably blows up with "invalid version" and "non-numeric" value and what not.

I've tried changing the pom and the manifest in various permutations but nothing seems to work. Is this not possible?Â

Perhaps I'm missing something.

-- 
Raymond AugÃÂ(@rotty3000)
Senior Software Architect
Liferay, Inc.Â(@Liferay)