[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Declarative Service and support of TargetPID ?

We just share the same felix scr package for interrogating the DS runtime.  There was no spec'ed way to do this and we did not want to re-invent something felix had already designed a solution for.  In the future R6 specification there is going to be standard DTOs for DS that can be used instead.  Speaking of which, Equinox is in need of someone to step up to implement and own the DS implementation.  As of now the existing contributors have not stepped forward to put forth the efforts necessary to implement all the changes coming to DS for OSGi R6.

So if anyone is interested and have the resources to do so please let me know if you would like to start contributing to the Equinox DS implementation.

Tom





From:        Cristiano Gavião <cvgaviao@xxxxxxxxx>
To:        equinox-dev@xxxxxxxxxxx
Date:        08/25/2014 10:39 AM
Subject:        Re: [equinox-dev] Declarative Service and support of  TargetPID ?
Sent by:        equinox-dev-bounces@xxxxxxxxxxx




Thanks Tom...

One doubt. I could see the package org.apache.felix.scr on the org.eclipse.equinox.ds bundle. what is the relation of the felix implementation with the equinox one?

regards,

Cristiano

On 25-08-2014 11:52, Thomas Watson wrote:
I do not think the Equinox DS implementation correctly supports targeted pids (see https://bugs.eclipse.org/bugs/show_bug.cgi?id=410361)

Tom





From:        
Cristiano Gavião <cvgaviao@xxxxxxxxx>
To:        
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
Date:        
08/25/2014 08:44 AM
Subject:        
[equinox-dev] Declarative Service and support of  TargetPID ?
Sent by:        
equinox-dev-bounces@xxxxxxxxxxx




Hello,

I'm trying to create a Configuration using a targetPID as defined in Configuration Admin Service spec 1.5(cmpn.5.0).

I created a factory config using this targetPID:
servicefactory1|org.c4biz.utils.osgi.itests.samples.bundle|88.0.0
and CM seems have properly created the PID and properties are ok too:
 servicefactory1|org.c4biz.utils.osgi.itests.samples.bundle|88.0.0-1408970963277-1

Even the configuration being properly created my declarative services based component (using configuration-policy = require) are not being activated with that configuration. but when I try with 'servicefactory1' only it works as expected.

So, am I missing something or Equinox DS doesn't support TargetPID yet ?

thanks,

Cristiano
_______________________________________________
equinox-dev mailing list

equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit

https://dev.eclipse.org/mailman/listinfo/equinox-dev


_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev