[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Update OSGi framework embedded for org.eclipse.equinox.servletbridge_1.2.300.v20130508-1243

Problem has been solved by deploying to a standalone Tomcat instance instead of running inside Eclipse Kepler. I am not sure exactly why; related to cached Eclipse workspace? ...Â

However, "version" defined in feature.xml didn't seem to matter. I just dropped in the newer version equinox jars, and restart, and the equinox version was updated.

Thanks a lot for the help!


On Fri, Jul 18, 2014 at 9:34 AM, Thomas Watson <tjwatson@xxxxxxxxxx> wrote:

Equinox 4.4 (Luna) [1] release includes the following version of org.eclipse.osgi: Âorg.eclipse.osgi_3.10.0.v20140606-1445.jar

Perhaps you are configuring the wrong version?

Also, be aware of bug https://bugs.eclipse.org/bugs/show_bug.cgi?id=412984Âyou will need to upgrade the servlet bridge itself to be able to work with the latest Equinox Luna release.

Tom

[1] http://download.eclipse.org/equinox/drops/R-Luna-201406061215/index.php


Inactive hide details for David Cao ---07/18/2014 04:18:36 AM---Hello there, I downloaded bridge.war and have it deployed to ToDavid Cao ---07/18/2014 04:18:36 AM---Hello there, I downloaded bridge.war and have it deployed to Tomcat 6; and it worked

From: David Cao <govelogo@xxxxxxxxx>
To: equinox-dev@xxxxxxxxxxx
Date: 07/18/2014 04:18 AM
Subject: [equinox-dev] Update OSGi framework embedded for org.eclipse.equinox.servletbridge_1.2.300.v20130508-1243
Sent by: equinox-dev-bounces@xxxxxxxxxxx





Hello there,Â

I downloaded bridge.war and have it deployed to Tomcat 6; and it worked fine. Now I like to upgrade the OSGi version embedded in the bridge. I did this,

1. download latest equinox framework (R4_4);Â
2. replace the equinox bundles in WEB-INF/eclipse/plugins folder with the new ones;Â
3. updateÂ\WEB-INF\eclipse\features\org.eclipse.equinox.servletbridge.feature_1.0.0\feature.xml of plugin versions to updated ones, e.g.
 Â<plugin
    Âid="org.eclipse.osgi"
    Âdownload-size="0"
    Âinstall-size="0"
    Âversion="3.9.1.v20140110-1610"
    Âunpack="false"/>

Then I started Tomcat, I was hoping to see framework is updated to 3.9.1. But instead I see following exception in console,Â

So, 1st, am I doing something legal here? and what has been wrong? or do I need to updateÂorg.eclipse.equinox.servletbridge as well? Thanks!!

Jul 18, 2014 6:13:29 AM org.apache.catalina.core.ApplicationContext log
SEVERE: Error while starting Framework
java.lang.RuntimeException: Could not find framework
at org.eclipse.equinox.servletbridge.FrameworkLauncher.findFrameworkURLs(FrameworkLauncher.java:443)
at org.eclipse.equinox.servletbridge.FrameworkLauncher.start(FrameworkLauncher.java:400)
at org.eclipse.equinox.servletbridge.BridgeServlet.init(BridgeServlet.java:83)
at javax.servlet.GenericServlet.init(GenericServlet.java:212)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1213)
...

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev


_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
To change your delivery options, retrieve your password, or unsubscribe from this list, visit
https://dev.eclipse.org/mailman/listinfo/equinox-dev