[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Update OSGi framework embedded for org.eclipse.equinox.servletbridge_1.2.300.v20130508-1243

Hello there,Â

I downloaded bridge.war and have it deployed to Tomcat 6; and it worked fine. Now I like to upgrade the OSGi version embedded in the bridge. I did this,

1. download latest equinox framework (R4_4);Â
2. replace the equinox bundles in WEB-INF/eclipse/plugins folder with the new ones;Â
3. updateÂ\WEB-INF\eclipse\features\org.eclipse.equinox.servletbridge.feature_1.0.0\feature.xml of plugin versions to updated ones, e.g.
 Â<plugin
    Âid="org.eclipse.osgi"
    Âdownload-size="0"
    Âinstall-size="0"
    Âversion="3.9.1.v20140110-1610"
    Âunpack="false"/>

Then I started Tomcat, I was hoping to see framework is updated to 3.9.1. But instead I see following exception in console,Â

So, 1st, am I doing something legal here? and what has been wrong? or do I need to updateÂorg.eclipse.equinox.servletbridge as well? Thanks!!

Jul 18, 2014 6:13:29 AM org.apache.catalina.core.ApplicationContext log
SEVERE: Error while starting Framework
java.lang.RuntimeException: Could not find framework
at org.eclipse.equinox.servletbridge.FrameworkLauncher.findFrameworkURLs(FrameworkLauncher.java:443)
at org.eclipse.equinox.servletbridge.FrameworkLauncher.start(FrameworkLauncher.java:400)
at org.eclipse.equinox.servletbridge.BridgeServlet.init(BridgeServlet.java:83)
at javax.servlet.GenericServlet.init(GenericServlet.java:212)
at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1213)
...