[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [e4-dev] Resolver Problem with guava and e4 (javax.annotation)

> I don't think so because from their point of view they are requireing
> JavaSE-1.6 and so they can wire to javax.annotation without packages.
>
> They could remove the javax.annotation import completely because they
> anyways require JavaSE-1.6


Well, not quite.

javax.annotation 1.0.0 has a BREE of 1.5  (but is "native" to only 1.6, according tohttps://bugs.eclipse.org/bugs/show_bug.cgi?id=422981#c5  )
javax.annotation 1.1.0 has a BREE of 1.5  (but is "native" to only 1.7, according to '')
javax.annotation 1.2.0 has a BREE of 1.6  (but is "native" to only 1.8, according to '' -- I think -- assuming it "made it in", but I do not know for sure)

The idea being that projects could use annotations, as the specs came out, even on an "older" VM, rather than have to wait for the JRE that first contained it.