[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Serious problems with EE Java 1.8 (and EE resolving in general) on Luna

Hi Tom,

Filed as https://bugs.eclipse.org/bugs/show_bug.cgi?id=432485

Tom

On 09.04.14 14:46, Thomas Watson wrote:
> Either way open a bug.  In Kepler we used to detect EE changes and force
> a re-resolve of everything on restart.  I thought that was being done in
> Luna, but it sounds like it is not.
> 
> Tom
> 
> 
> 
> Inactive hide details for BJ Hargrave---04/09/2014 07:43:42 AM---If you
> change the underlying JRE, you should probably launch wBJ
> Hargrave---04/09/2014 07:43:42 AM---If you change the underlying JRE,
> you should probably launch with -clean  to flush the cached resolv
> 
> From: BJ Hargrave/Austin/IBM@IBMUS
> To: Equinox development mailing list <equinox-dev@xxxxxxxxxxx>,
> Date: 04/09/2014 07:43 AM
> Subject: Re: [equinox-dev] Serious problems with EE Java 1.8 (and EE
> resolving in general) on Luna
> Sent by: equinox-dev-bounces@xxxxxxxxxxx
> 
> ------------------------------------------------------------------------
> 
> 
> 
> If you change the underlying JRE, you should probably launch with -clean
> to flush the cached resolve state. 
> -- 
> 
>     *BJ Hargrave*
>     Senior Technical Staff Member, IBM
>     OSGi Fellow and CTO of the _OSGi Alliance_ <http://www.osgi.org/>_
>     __hargrave@xxxxxxxxxxx <mailto:hargrave@xxxxxxxxxx> 
> 
> 	
> 
> office: +1 386 848 1781
> mobile: +1 386 848 3788
> 
> 
> 
> 
> 
> From:        Tom Schindl <tom.schindl@xxxxxxxxxxxxxxx> 
> To:        equinox-dev@xxxxxxxxxxx 
> Date:        2014/04/09 08:16 
> Subject:        [equinox-dev] Serious problems with EE Java 1.8 (and EE
> resolving in general) on Luna 
> Sent by:        equinox-dev-bounces@xxxxxxxxxxx 
> 
> ------------------------------------------------------------------------
> 
> 
> 
> Hi,
> 
> I'm encountering strange problems with Luna M6 and EE 1.8. The scenario
> is like this:
> 
> We provide a prebuilt distro where bundles require an EE of 1.8 if I
> download this distro and launch the IDE with a JDK 1.7 naturally those
> bundles do not resolve but stay in the INSTALLED state and a diag
> appropriately tells me
> 
>> osgi> diag 205
>> org.eclipse.fx.core [205]
>>   Unresolved requirement: Require-Capability: osgi.ee;
> filter:="(&(osgi.ee=JavaSE)(version=1.8))"
>>
>> osgi>
> 
> Everything ok but now the strange thing starts to happen. If I shutdown
> the IDE and then launch with JDK8 the bundles do not get resolved either
> and diag reports the same problem so it looks like the resolve is cached!
> 
> BTW the same is true the other way round as well:
> * Launch with Java8 (EE 1.8 bundles are RESOLVED)
> * Launch with Java7 (EE 1.8 bundles are STILL RESOLVED)
> 
> I think this is a major Bug in Equinox on Luna!
> 
> Tom
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxxx
> __https://dev.eclipse.org/mailman/listinfo/equinox-dev_
> 
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> 
> 
> 
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>