[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Uses conflicts gone after "eclipse -clean":Why?

Yes, check out the Bundle Wiring API specification (chapter 7 of the core spec).

Specifically the FrameworkWiring.refreshBundles() method can be used to force refresh and re-resolution of a subset of bundles.

Regards,
Neil


On Fri, Apr 4, 2014 at 1:45 PM, Andreas Sewe <andreas.sewe@xxxxxxxxxxxxxx> wrote:
Hi all,

> The point is that in OSGi, resolution proceeds from the current wiring
> state, and sometimes a set of bundles would fail with a uses-constraint
> violation if installed on the top of the current wiring state. However
> if you're prepared to break apart and rewire the existing state, then a
> solution can often be found.

is there a way to force a rewiring upon an install of a bundle/feature?
We have a very nasty bundle upgrade problem that runs into uses
conflicts as another bundle (org.eclipse.m2e.maven.runtime)
overzealously claims that it exports version 0.0.0 of many, many
packages, some of which we require in a specific, different version.

Best wishes,

Andreas

--
Codetrails UG (haftungsbeschrÃnkt)
The knowledge transfer company

Robert-Bosch-Str. 7, 64293 Darmstadt
Mobile: +49-170-811-3791
http://www.codetrails.com/

Managing Director: Dr. Marcel Bruch
Handelsregister: Darmstadt HRB 91940
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev