[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Changes to weaving related projects.

Some changes [1] were recently made to the weaving related projects [2] in order to fix compile issues in the official build. I would like to highlight a couple here in case there are any concerns. The rest can be viewed in the commit [1].

Because of how the official build works, the system bundle fragment org.eclipse.equinox.weaving.hook needs to use the same BREE as its host (org.eclipse.osgi) which is JavaSE-1.6. Because the other weaving projects import a package from the fragment, their BREE needs to match the fragment's.

The org.eclipse.jdt.core.compiler.missingOverrideAnnotation setting in org.eclipse.jdt.core.prefs was changed from "warning" to "ignore" in the project specific settings. This matches the official build settings and avoids numerous compile warnings in the workspace due to missing @Override annotations on interface methods with the bump to JavaSE-1.6. The warnings can be fixed of course, but we chose the current approach for now in case we end up having to change the BREE back to 1.5.

Please shout if you have any issues or concerns.

John

[1] http://git.eclipse.org/c/equinox/rt.equinox.bundles.git/commit/?id=ffc01eb1a49bf6df176f646d8d30c6a39179fb12

[2] org.eclipse.equinox.weaving.aspectj, org.eclipse.equinox.weaving.caching, org.eclipse.equinox.weaving.caching.j9, org.eclipse.equinox.weaving.hook