[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Java 5 no longer supported as runtime?

Hi Michael,

Java 5 was not a supported target for any 4.x Eclipse (see project plans
for 4.2 [1], 4.3 [2] and 4.4 [3]) - and this was for sure announced.
That's a general statement.

The Equinox specific announcement is here
http://dev.eclipse.org/mhonarc/lists/equinox-dev/msg07586.html with
details pointing to
http://wiki.eclipse.org/Equinox/Luna_Framework#Requirement_on_Java_6.

I agree it was easy to miss that change, so I'm cross-posting this
message to equinox-dev - and I propose keep the discussion running
there.

BTW. MANIFEST.MF of org.eclipse.osgi lists 1.5 as supported ee. I think
it is a bug.

[1]
http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_2.xml
[2]
http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_3.xml
[3]
http://www.eclipse.org/projects/project-plan.php?planurl=http://www.eclipse.org/eclipse/development/plans/eclipse_project_plan_4_4.xml

-- 
Krzysztof Daniel <kdaniel@xxxxxxxxxx>
Red Hat