[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Equinox, PDE and packages from the ExtensionClasspath (e.g. JavaFX)

Am 14.11.2012 01:30, schrieb Neil Bartlett:
> I really feel that the problem is in the launcher, so that's where it
> needs to be fixed, i.e. by setting the osgi.parentClassloader=app system
> property.

I agree. So the wrong property is only used if the Equinox is launched
using the binary executable or also when launched using "java -jar
org.eclipse.osgi..."?

I think the dilema is that anything that requires a "fix" will make
adoption harder because people won't be able to use released versions
(eg., Juno) for JavaFX development. Is that correct?

-Gunnar

-- 
Gunnar Wagenknecht
gunnar@xxxxxxxxxxxxxxx
http://wagenknecht.org/