[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Equinox Framework and several bundles moving up to Java SE 5 in Kepler

The following bundles (and framework) are moving up to Java SE 5 in Kepler M3:

  org.eclipse.osgi (the framework)
  org.eclipse.equinox.supplement
  org.eclipse.equinox.coordinator
  org.eclipse.equinox.event
  org.eclipse.equinox.metatype

The framework and these equinox bundles have long supported J2ME Foundation VMs.  The OSGi R4.3 specification introduced generics to the API but we still continued to support J2ME by using the jsr14 compiler flag to compile the source into a binary that could still run on J2SE 1.4 based VMs (including J2ME).  With Java 7 the compiler (javac not the eclipse compiler) no longer supports class files compiled with the jsr14 option see [1] for more details.  J2SE 1.4 has long been considered end of life and our ability to support J2ME over the years has become more and more difficult.  Instead of continuing to try and use the jsr14 flag we have decided to simply move up to Java SE 5.  If Java 8 ends up including compact profiles [2] then we will of coarse look to supporting the smallest profile possible.

Tom

[1] https://bugs.eclipse.org/bugs/show_bug.cgi?id=369145

[2] http://openjdk.java.net/jeps/161