[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Introduction of the org.osgi.framework.VersionRange

Now that we are finished (are finishing?) M4 this week I wanted to let you
know about a change in equinox that happened early in M5.  OSGi has
introduced a new class org.osgi.framework.VersionRange (bug
https://bugs.eclipse.org/bugs/show_bug.cgi?id=365353).  Normally adding new
classes would not justify an announcement to the cross-project list, but in
this case I am aware of at least two other VersionRange classes in the
Equinox project alone:

	org.eclipse.equinox.p2.metadata.VersionRange and
	org.eclipse.osgi.service.resolver.VersionRange

The introduction of the org.osgi.framework.VersionRange may cause you to
start having compile errors for ambiguity with the VersionRange classes.
If you use either of the above classes you should try to compile your code
against on of the early M5 integration builds from the eclipse or equinox
project to ensure you have proper imports in your java code to avoid the
ambiguity.  This change is already included in the latest integration
builds of the eclipse and equinox projects.

Let me know if you have any questions.

Tom