[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Difference in system.packages.extra behaviour between 3.6.2 and 3.7

Hi Ben,

I don't use PDE any more, but I think as a workaround you should be
able to create a system bundle fragment (i.e. "Fragment-Host:
system.bundle") to export the desired package(s). You may need to
manually construct this outside of PDE and put it in your Target
Platform, but once done it will make those packages visible to the PDE
builder.

However I would probably not wish to deploy that fragment at runtimeâ
cleaner to use the system.packages.extra approach that you're already
using.

Regards,
Neil

On Thu, Sep 8, 2011 at 3:38 PM, Ben Cox <benjamin.cox@xxxxxxxxxx> wrote:
> Thanks, Tom, Neil, Alex.
>
> Tom, you got it! As you'd figured out, yes we are using the standard OSGi
> launcher, and adding osgi.compatibility.bootdelegation=true makes it work
> again. Thanks for the precise link to the bug report.
>
> Re Neil: looking back at this, I was actually surprised that it worked at
> all without the Import-Package! It really does need it, in accordance with
> the spec. I'll have a discussion with the PDE folks as to how
> system.packages.extra can be better supported, and have a go at coding it up
> if I can.
>
> Thanks again,
> Ben
>
>
> ________________________________
>
> Unless stated otherwise above:
> IBM United Kingdom Limited - Registered in England and Wales with number
> 741598.
> Registered office: PO Box 41, North Harbour, Portsmouth, Hampshire PO6 3AU
>
>
>
>
>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>
>