[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] How to set activate on startup to 'true' in bundles.info file

Hi Neil/devs,

On Tue, Aug 16, 2011 at 8:56 AM, Neil Bartlett <njbartlett@xxxxxxxxx> wrote:
> I don't actually know the answer to your question, but I'm hoping the
> answer is "no, that's not possible".

Yes I got your point. I too think you are correct here.
But I'm not clear the what makes it 'true' or 'true' in the bundles.info file.

like, "all bundles that has an activator will be activated by startup."

may be this is a trivial question, but I couldnt find a document
explaining that.


thanks,
--Pradeep

>
> Your bundle probably does not need to be activated when Eclipse is
> started. If you and all other plug-in authors were able to do this,
> then Eclipse would take hours to start.
>
> Please consider other ways to achieve what you want to do.
>
> Rgds,
> Neil
>
> On Tue, Aug 16, 2011 at 4:11 AM, Pradeep Fernando <pradeepfn@xxxxxxxxx> wrote:
>> Hi devs,
>>
>> I have a p2-aware product that uses simpleconfigurator. In the
>> bundles.info file the activate on startup field is set to 'false' for
>> most of the bundles.
>> How simpleconfigurator decides weather to put to 'false' or 'true' in
>> bundles.info. Is it possible to make the default value to 'true'.
>> (activate bundle at startup)
>>
>>
>> Thanks,
>> --Pradeep Fernando
>> _______________________________________________
>> equinox-dev mailing list
>> equinox-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>



-- 
Pradeep Fernando.
http://pradeepfernando.blogspot.com/