[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] List of installable units or log - using p2 director to automate Subclipse, M2eclipse, and M2eclipse Extra for OpenMRS developers

[...]

> Somewhat oddly (to me) the relevant reference to the Update Manager API on
> Galileo:
> http://help.eclipse.org/galileo/index.jsp?topic=/org.eclipse.platform.doc.isv/reference/api/org/eclipse/update/core/package-summary.html
> is marked as deprecated. I don't easily see a replacement API present, so, I
> am left to wonder, as I need to support Galileo in my implementation - am I
> missing something or is the Update Manager API indeed the best/only way to
> install features from a plug-in in Galileo?
	p2 has been around since 3.4 and it had a provisional API in 3.4 and 3.5.
It is only since 3.6 that p2 has an official API.  I definitely recommend staying out of update manager API and use the p2 provisional API instead. Though in different packages, the final APIs are really close to the provisional one and once you will have figured out how to make your installer work on 3.6, making it work in only a few package and method renames away.
	The other important point is that the metadata is compatible so you would not have to generate two sets of information.