[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Generated configuration file overwrites specified properties


How did you build this product?
The metadata for the product generally specifies the settings for these properties.

Here it looks like you are getting the settings that are specified by the org.eclipse.platform.ide product.  Are you just taking the platform.ide and copying your stuff over top of it?
It sounds like the p2 metadata just has the platform.ide settings, on first start p2 discovers the bundles you copied on top of everything reconciles the install for you, this would cause the configuration settings to be regenerated.

I would suggest taking a look at these two examples I wrote last year:
http://aniefer.blogspot.com/2009/07/composing-and-updating-custom-eclipse.html
http://aniefer.blogspot.com/2009/07/adt-part-2-more-like-epp.html

It is probably simplest to build things as described in the second post (ADT part 2: More like the EPP), though it would be good to read the first post as well.  They both contain references to examples in cvs that you can download and run.

-Andrew


From: Richard Horbach <richard.horbach@xxxxxxxxxx>
To: equinox-dev@xxxxxxxxxxx
Date: 03/23/2010 10:01 AM
Subject: [equinox-dev] Generated configuration file overwrites specified        properties
Sent by: equinox-dev-bounces@xxxxxxxxxxx





We start our product, based on Eclipse, with our own splash screen. In
the configuration directory we therefore have specified the following
properties in the config.ini file:
- eclipse.product=com.mycompany.myproduct.ide
- osgi.splashPath=platform\:/base/plugins/com.mycompany.myprod uct
- osgi.configuration.area = @user.home/.eclipse/configuration

When starting the product for the very first time, the proper splash
screen shows up. Therefore, the local config.ini file was read and
parsed correctly. When closing the application again, a new created
configuration file is written (written by EquinoxFwConfigFileParser) to
the location specified in 'osgi.configuration.area'. This generated
config.ini file however, contains wrong/overwritten properties:
- eclipse.product=org.eclipse.platform.ide
- osgi.splashPath=platform\:/base/plugins/org.eclipse.platform

If I now restart the product for a second/next time, the default Eclipse
splash screen is shown; The setting in the configuration area apparently
takes precedence over the local setting.

I have this problem since I switched over from Eclipse 3.5.0 to version
3.5.2. In Eclipse 3.5.0 this mechanism worked well, since no entries for
'eclipse.product' and 'osgi.splashPath' were written back.

Should I log a bug in bugzilla for this issue, or could there be
something wrong with my configuration?

Regards,
Richard Horbach
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev