[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Problem Exporting Bundle with Native Libraries include in Eclipse

Hi,

 

This problem just happens when I work with Eclipse on Windows XP, if I tried the same step in Ubuntu I do not get any error at all.

 

Any idea?

 

Regards

 

De: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] En nombre de David Conde
Enviado el: lunes, 24 de agosto de 2009 12:32
Para: 'Equinox development mailing list'
Asunto: [equinox-dev] Problem Exporting Bundle with Native Libraries include in Eclipse

 

Hi,

 

I am triying to run a bundle which is expected to contain native libraries to be used by other bundles. The problem is that when I try to Export this bundle I get the next error:

 

Error

Reason:

 Problems during export

<<Details:

Unable to find plug-in: MyPluginName_1.0.0.

 

It is very strange because I am just creating a new bundle from JAR FILE, and create a folder where I save a native library called mylibrary.so and the only thing that I do is to include the next Header to the Manifest.MF:

 

Bundle-NativeCode: libjunixsocket.so ;

 processor = i386 ; osname = Linux

 

I do not get any compilation error so that should work fine.

 

Any idea?


Thank you in advance

 

Regards