[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Problem testing with JUnit - Equinox doesn't start

Hi,
do you know any online resources which explain how to test bundle
code with JUnit and Equinox?
I've tried to setup the test suite in Eclipse Ganymede and don't get
Equinox to start up when running the tests.


!ENTRY org.eclipse.osgi 4 0 2009-06-12 00:57:41.198
!MESSAGE An unexpected runtime error has occurred.
!STACK 0
java.lang.IllegalArgumentException: The System Bundle's start level can
not be
modified.
at
org.eclipse.osgi.framework.internal.core.StartLevelManager
.setBundleStartLevel(StartLevelManager.java:415)
at
org.eclipse.core.runtime.adaptor.EclipseStarter
.installBundles(EclipseStarter.java:1122)
at
org.eclipse.core.runtime.adaptor.EclipseStarter
.loadBasicBundles(EclipseStarter.java:646)
at
org.eclipse.core.runtime.adaptor.EclipseStarter
.access$1(EclipseStarter.java:623)
at
org.eclipse.core.runtime.adaptor.EclipseStarter$1
.bundleChanged(EclipseStarter.java:308)
at
org.eclipse.osgi.framework.internal.core.BundleContextImpl
.dispatchEvent(BundleContextImpl.java:1234)
at
org.eclipse.osgi.framework.eventmgr.EventManager
.dispatchEvent(EventManager.java:211)
at
org.eclipse.osgi.framework.eventmgr.ListenerQueue
.dispatchEventSynchronous(ListenerQueue.java:141)
at
org.eclipse.osgi.framework.internal.core.Framework
.publishBundleEventPrivileged(Framework.java:1518)
at
org.eclipse.osgi.framework.internal.core.Framework
.publishBundleEvent(Framework.java:1469)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager
.doSetStartLevel(StartLevelManager.java:281)
at
org.eclipse.osgi.framework.internal.core.StartLevelManager
.launch(StartLevelManager.java:247)
at
org.eclipse.osgi.framework.internal.core.SystemBundle
.resume(SystemBundle.java:201)
at
org.eclipse.osgi.framework.internal.core.Framework
.launch(Framework.java:644)
at org.eclipse.osgi.framework.internal.core.OSGi.launch(OSGi.java:51)
at
org.eclipse.core.runtime.adaptor.EclipseStarter
.startup(EclipseStarter.java:313)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl
.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)


Followed by

!ENTRY org.eclipse.osgi 4 0 2009-06-12 00:57:41.202
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Platform not running
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:374)
at
org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at
sun.reflect.DelegatingMethodAccessorImpl
.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)


And followed by hundreds of

!ENTRY org.eclipse.osgi 2 0 2009-06-12 00:57:41.296
!MESSAGE One or more bundles are not resolved because the following root
constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2009-06-12 00:57:41.296
!MESSAGE Bundle
initial@reference:file:plugins/
org.eclipse.jdt.junit4.runtime_1.0.200.v20080603-2000.jar/
was not resolved.
!SUBENTRY 2 org.eclipse.jdt.junit4.runtime 2 0 2009-06-12 00:57:41.296
!MESSAGE Missing required bundle org.junit4_[4.2.0,4.4.0).


But all those bundles are selected in the plugin section of the test run
configuration.

Thanks for your help
Markus