[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Help Request - Equinox error when starting Eclipse - crash

Hi all, I’m hoping someone could help me with this error I’ve been suddenly getting out of the blue.

 

!SESSION 2009-05-30 21:18:26.150 -----------------------------------------------

eclipse.buildId=M20090211-1700

java.version=1.6.0_12

java.vendor=Sun Microsystems Inc.

BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

Command-line arguments:  -os win32 -ws win32 -arch x86

 

!ENTRY org.eclipse.osgi 4 0 2009-05-30 21:18:26.876

!MESSAGE Application error

!STACK 1

java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

 at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:74)

 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)

 at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

 at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

 at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

 at java.lang.reflect.Method.invoke(Unknown Source)

 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)

 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)

 at org.eclipse.equinox.launcher.Main.run(Main.java:1236)

 

 

and this is the config.ini file:

 

#This configuration file was written by: org.eclipse.equinox.internal.frameworkadmin.equinox.EquinoxFwConfigFileParser

#Fri May 29 21:30:25 CEST 2009

osgi.launcherPath=.

org.eclipse.update.reconcile=false

eclipse.p2.profile="">

osgi.instance.area.default=@xxxxxxxxx/workspace

osgi.framework=file\:plugins\\org.eclipse.osgi_3.4.3.R34x_v20081215-1030.jar

eclipse.buildId=M20090211-1700

osgi.bundles=reference\:file\:org.eclipse.equinox.weaving.hook_1.0.0.200901261628.jar@4,reference\:file\:org.eclipse.equinox.simpleconfigurator_1.0.0.v20080604.jar@1\:start

org.eclipse.equinox.simpleconfigurator.configUrl=file\:org.eclipse.equinox.simpleconfigurator\\bundles.info

eclipse.product=org.eclipse.sdk.ide

osgi.splashPath=platform\:/base/plugins/org.eclipse.platform

osgi.launcherIni=eclipse

eclipse.p2.data.area=@xxxxxxxxxx/../p2

osgi.bundles.defaultStartLevel=4

 

Could anyone help me work out why eclipse won’t start and how to fix it, maybe also explain “why” it just happened and point me to some web resources to understand more in the future about the causes of such issues? I’m not new to eclipse but I don’t even know where to begin understanding how it works and how to interpret it’s errors.

 

Thanks a lot in advance!

 

Razvan