[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] osgi.resolver.usesMode in PDE

On Tue, Apr 28, 2009 at 4:29 PM, Chris Aniszczyk <zx@xxxxxxxxxxxxxxxxx> wrote:
> On Tue, Apr 28, 2009 at 8:51 AM, Thomas Watson <tjwatson@xxxxxxxxxx> wrote:
>>
>> PDE uses its own set of configuration properties for the resolver at
>> development time. PDE could have an option to add that property to the
>> configuration of the resolver state used in PDE. This is not something
>> Equinox can control though. You should probably open a bug against PDE-UI to
>> consider doing this. I imagine a similar bug would need to be opened against
>> PDE-Build to support this if you wanted to do headless builds.
>
> Feel free to open up a bug against PDE. The heart of this issue lays in
> Equinox though:
>
> 216934: [plan] Performance issues with the Export-Package "uses" directive
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=216934

As I understand it, this probem is basically not solvable. Therefore
the usesMode property was introduced in Equinox, so the effects of the
problem could be contained. However, that means that PDE now possibly
resolves differently then runtime Equinox.

Tom

>
> Cheers,
>
> --
> Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465
> http://twitter.com/eclipsesource | http://twitter.com/caniszczyk
>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>
>