[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Autostarting Bundles

I suggest you open a bug against PDE-UI to document the issue. Thanks.

Tom



Inactive hide details for "O'Flynn, Dennis" ---04/20/2009 11:33:35 AM---Chris,"O'Flynn, Dennis" ---04/20/2009 11:33:35 AM---Chris,


From:

"O'Flynn, Dennis" <Dennis.OFlynn@xxxxxxxxxxxxx>

To:

"Equinox development mailing list" <equinox-dev@xxxxxxxxxxx>

Date:

04/20/2009 11:33 AM

Subject:

RE: [equinox-dev] Autostarting Bundles




Chris,

I just verified my use cases. The bundle.info is not created when the .product definition is based upon plug-in configurations.

Use case 1: .product definition is configured based upon plug-ins
* o.e.e.simpleconfigurator is identified as one of the plug-ins
* o.e.e.simpleconfigurator is identified as a bundle to be auto-started
* exported the product
** the /configuration folder only contains a config.ini
** sub-folder for o.e.e.simpleconfigurator/bundle.info does NOT exist

Use case 2: .product definition to be configured upon features
* created a feature with the same plug-ins used in the .product plug-in configuration above
* o.e.e.simpleconfigutor is identified as a plug-in included with the feature
* o.e.e.simpleconfigurator is identified as a bundle to be auto-started
* exported the product, the /configuration folder only contains a config.ini
** the /configuration folder contains a config.ini
** sub-folder for o.e.e.simpleconfigurator/bundle.info exists



The contents of this e-mail are intended for the named addressee only. It contains information that may be confidential. Unless you are the named addressee or an authorized designee, you may not copy or use it, or disclose it to anyone else. If you received it in error please notify us immediately and then destroy it
.
From: equinox-dev-bounces@xxxxxxxxxxx [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of Chris Aniszczyk
Sent:
Monday, April 20, 2009 10:47 AM
To:
Equinox development mailing list
Subject:
Re: [equinox-dev] Autostarting Bundles

On Mon, Apr 20, 2009 at 9:44 AM, O'Flynn, Dennis <Dennis.OFlynn@xxxxxxxxxxxxx> wrote:

Andâ

It appears that the product definition needs be based upon feature configuration, not plug-ins. When I tried this using plug-in based configuration, the config.ini contained a fully defined osgi.bundles, with no bundle.info. When I switched to a feature based configuration, a bundle.info was generated.

This is probably because you weren't including o.e.equinox.simpleconfigurator in your plug-in configuration. That's how we know you imply to use p2.

Cheers,


--
Chris Aniszczyk | EclipseSource Austin | +1 860 839 2465

http://twitter.com/eclipsesource | http://twitter.com/caniszczyk

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev

GIF image

GIF image