[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] DS deployment question

I'm not sure what's going on Kai, but if you do -Dequinox.ds.print=true you should get debug output from DS.

On Wed, Jan 14, 2009 at 8:44 AM, Toedter, Kai <kai.toedter@xxxxxxxxxxx> wrote:
Hi All,

I am currently working on the deployment of my OSGi/Equinox demo (see http://max-server.myftp.org/trac/pm). While launching the demo from an Eclipse SDK, everything works fine. But when I deploy all the bundles together with a config.ini file, the main service component (just a component, not a service itself) is not instantiated.

Here is my config.ini:
osgi.bundles=org.eclipse.equinox.util@start,org.eclipse.equinox.ds@start,org.eclipse.osgi.services@start,org.jdesktop.application@start,com.siemens.ct.pm.application@start,com.siemens.ct.pm.model@start,com.siemens.ct.pm.ui.actions.save@start,com.siemens.ct.pm.ui.actions.person@start,com.siemens.ct.pm.ui.views.bundleview@start
eclipse.ignoreApp=true

Here is the XML of the service component that is not instantiated in the deployed version:
<component name="uiServiceManager">
<implementation
 class="com.siemens.ct.pm.application.PersonManagerApplicationComponent"/>
 <reference name="ActionContribution"
   interface="com.siemens.ct.pm.application.service.IActionContribution"
   bind="setActionContribution"
   unbind="unsetActionContribution"
   cardinality="0..n"
   policy="dynamic"
 />
 <reference name="ViewContribution"
   interface="com.siemens.ct.pm.application.service.IViewContribution"
   bind="setViewContribution"
   unbind="unsetViewContribution"
   cardinality="0..n"
   policy="dynamic"
 />
</component>

The deployed bundles look fine to me, after starting OSGi all bundles are ACTIVE:
id      State       Bundle
0       ACTIVE      org.eclipse.osgi_3.4.0.v20080605-1900
1       ACTIVE      org.eclipse.equinox.util_1.0.0.v20080414
2       ACTIVE      org.eclipse.equinox.ds_1.0.0.v20080427-0830
3       ACTIVE      org.eclipse.osgi.services_3.1.200.v20071203
4       ACTIVE      org.jdesktop.application_1.0.4
5       ACTIVE      com.siemens.ct.pm.application_1.0.0.200901141513
6       ACTIVE      com.siemens.ct.pm.model_1.0.0.200901141513
7       ACTIVE      com.siemens.ct.pm.ui.actions.save_1.0.0.200901141513
8       ACTIVE      com.siemens.ct.pm.ui.actions.person_1.0.0.200901141513
9       ACTIVE      com.siemens.ct.pm.ui.views.bundleview_1.0.0.200901141513

Why is the component instantiated, when I launch exactly the same set of bundles from Eclipse and why not, when I launch from a batch file, like

java -jar plugins/org.eclipse.osgi_3.4.0.v20080605-1900.jar -console

Any hints?

Thanks a lot


Kai TÃdter

Siemens AG
Corporate Technology
Architecture
CT SE 2
Otto-Hahn-Ring 6
81739 Munich, Germany
Phone: +49 89 636-41064
Fax: +49 89 636-45450
mailto: kai.toedter@xxxxxxxxxxx
Internet: www.siemens.com/corporate-technology

Siemens Aktiengesellschaft: Chairman of the Supervisory Board: Gerhard Cromme; Managing Board: Peter Loescher, Chairman, President and Chief Executive Officer; Heinrich Hiesinger, Joe Kaeser, Rudi Lamprecht, Eduardo Montes, Juergen Radomski, Erich R. Reinhardt, Hermann Requardt, Uriel J. Sharef, Peter Y. Solmssen, Klaus Wucherer; Registered offices: Berlin and Munich; Commercial registries: Berlin Charlottenburg, HRB 12300, Munich, HRB 6684; WEEE-Reg.-No. DE 23691322


_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev