[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Update to Jetty and Servlet API in the M4 SDK

In M4 the platform team updated the version of Jetty that comes packaged with the SDK from 5.1 to 6.1.
This impacts the following bundles:

1) org.mortbay.jetty (version 5.1) (removed)
If your feature directly integrates with the Jetty 5 API you can continue to do so but must now add the appropriate bundles from Orbit yourself.

2) org.mortbay.jetty.server and org.mortbay.jetty.util (version 6.1) (added)

3) javax.servlet (upgraded from version 2.4 to 2.5)
API compatible. Bundle-Version and Export-Package version updated. Teams should verify version ranges for Import-Package and Require-Bundle.

4) org.eclipse.equinox.http.jetty (upgraded from version 1.1 to 2.0)
API compatible. Bundle Version updated but no change to Export-Package version. Teams using Require-Bundle with a restricted bundle-version range should confirm.

--
None of these changes introduce new Eclipse binary API or prevent the use of existing API.

If anyone has a problem please log a bug against RT->Equinox->Server-Side

-Simon