[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Match problem when updating p2-ized product

Hi Torkild,

Probably your product list a specific version of features (match perfect) as in:

requiredCapability: org.eclipse.equinox.p2.iu/com.atmel.avr32/[2.1.0.200809241313,2.1.0.200809241313] <-----Here
So you can not update/install this feature alone without break the product.
Solutions:


1. update the product itsef (your new version of the product must list com.atmel.avr32_2.1.0.200809241305
2. If you can change your product (rebuild it), just add a range for this feature (something like [2.1.0,2.1.9]) )


I presume you have only one installable unit (the product). in that case suggestion 1 is the better (IMHO).

Regards,

Gladyston




Torkild Ulvøy Resheim wrote:
I've got a product which consists of two of our features "com.atmel.avr32" and "com.atmel.avr32.doc". When attempting to upgrade an installation of this product using a p2 repository I always get this error message:

Cannot complete the request. See the details.
AVR32 Studio IDE Core is already installed, so an update will be performed instead.
AVR32 Studio User Guide is already installed, so an update will be performed instead.
Cannot find a solution where both Match[requiredCapability: org.eclipse.equinox.p2.iu/com.atmel.avr32/[2.1.0.200809241313,2.1.0.200809241313]] and Match[requiredCapability: org.eclipse.equinox.p2.iu/com.atmel.avr32/[2.1.0.200809241305,2.1.0.200809241305]] can be satisfied.
....many more


For some reason the feature cannot be updated (to 2.1.0.200809241313) because the older version of the feature is required (2.1.0.200809241305)

There are no dependencies where the version is not specified so that should not be the case. When looking at the "com.atmel.avr32" feature part of the generated "contents.xml" (for the original installation) I find the following:

<required namespace='org.eclipse.equinox.p2.iu' name='com.atmel.avr32.managedbuilder.ui' range='[2.1.0,3.0.0)'/>
<required namespace='org.eclipse.equinox.p2.iu' name='com.atmel.avr32.managedbuilder.ui' range='[2.1.0.200809241305,2.1.0.200809241305]'/>


Any ideas on how to resolve the update issue?