[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Is this a bug?

Yes, understand. I did get the bundle loaded via config.ini so that makes it loaded via reference. So if I were to write a bundle manager kind of bundle that used
Bundle.installBundle(String, InputStream) and
Bundle.installBundle(String)

to install bundles into my runtime passing file: urls - in that case I think I should be able to achieve what I am trying i.e dynamically loading/updating modules when needed.

Regards,
Vin.

--- On Wed, 9/24/08, Danail Nachev <d.nachev@xxxxxxxxxx> wrote:
From: Danail Nachev <d.nachev@xxxxxxxxxx>
Subject: Re: [equinox-dev] Is this a bug?
To: vjoshi2002@xxxxxxxxx, "Equinox development mailing list" <equinox-dev@xxxxxxxxxxx>
Date: Wednesday, September 24, 2008, 2:42 PM

If bundles are installed by reference (via reference: URL) Equinox
doesn't guarantee anything to bundles which you replace, while they are
still running. Although OSGi is considered dynamic, such scenarios are
not supported. AFAIK, p2 and old Eclipse Update installs all bundles by
reference.

Such scenarios can be supported if the bundle was copied to the Equinox
storage and not referenced. Bundles which are installed through
Bundle.installBundle(String, InputStream) and
Bundle.installBundle(String) are copied (unless the URL passed to the
installBundle(String) is reference: URL) are copied to the storage.

Does this answer your question?

BR,
--
Danail Nachev
Senior Software Engineer/Development Tools
ProSyst Labs EOOD
-------------------------------------------------
stay in touch with your product.
-------------------------------------------------

Vinayak Joshi wrote:
> Considering OSGI allows dynamic updates of running modules, I prototyped
> a situation where the equinox (v 3.4) is launched with a test bundle.
> Before calling any methods on the bundle, I replace the test bundle's
> jar file on the disk with a different copy - thereafter, the test bundle
> starts to throw class not found exceptions. I was hoping that until I
> issued an explicit bundle update, the test bundle would continue to work
> as though nothing changed.
>
> Is there something wrong with my understanding or is it a bug?
>
> I can provide sample test bundles to reproduce the issue.
>
> Vin.
>
>
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev