[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Missing feature brandings after RCP p2 install

Hi All,

I just filed a bug about the following behavior against Eclipse 3.4, see https://bugs.eclipse.org/bugs/show_bug.cgi?id=239227

1. Create an RCP app with feature branding and About dialog
2. Export the app using the export wizard (and create p2 repositories)
3. Check the About dialog in the exported version, you see the feature branding
icon.
4. Install the app (using p2 director) from the repository created during
export
5. Check the About dialog in the installed version, the feature branding icon
is gone :(

Rich Scott found out that that has something to do with the generated
config.ini, see his comment at http://toedter.com/blog/?p=27

I would appreciate any hints what I have to do to see the feature branding in RCP apps installed by p2?

Thanks

Kai
---

Kai Tödter

Siemens AG
Corporate Technology
Architecture
CT SE 2
Otto-Hahn-Ring 6
81739 Munich, Germany
Phone: +49 89 636-41064
Fax: +49 89 636-45450
mailto: kai.toedter@xxxxxxxxxxx
Internet: www.siemens.com/corporate-technology

Siemens Aktiengesellschaft: Chairman of the Supervisory Board: Gerhard Cromme; Managing Board: Peter Loescher, Chairman, President and Chief Executive Officer; Heinrich Hiesinger, Joe Kaeser, Rudi Lamprecht, Eduardo Montes, Juergen Radomski, Erich R. Reinhardt, Hermann Requardt, Uriel J. Sharef, Peter Y. Solmssen, Klaus Wucherer; Registered offices: Berlin and Munich; Commercial registries: Berlin Charlottenburg, HRB 12300, Munich, HRB 6684; WEEE-Reg.-No. DE 23691322