[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
RE: [equinox-dev] Calling p2 director by command linefreezesEclipseon splash screen

Hi Paul,

The .log file was in the <user_home>/workspace/.metadata directory. I didn't
know that Eclipse creates this workspace there since I was creating my
workspace on my installation directory. For this reason I haven't looked
there.

Looking at the log file, it is missing one of the artifacts named
"osgi.bundle". It sound stange because I can install the hello world plug-in
using the UI but not from the command line.

Below is the log content:

!SESSION 2008-06-17 09:20:03.361
-----------------------------------------------
eclipse.buildId=I20080609-1311
java.version=1.6.0_02
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -application
org.eclipse.equinox.p2.director.app.application -metadataRepository
file:/d:/myUS34 -artifactRepository file:/d:/myUS34 -installIU
myFeature34.feature.group -version 1.0.0 -destination
d:/eclipse_ganymede_RC4/eclipse_sdk -profile SDKProfile
Command-line arguments:  -os win32 -ws win32 -arch x86 -application
org.eclipse.equinox.p2.director.app.application -metadataRepository
file:/d:/myUS34 -artifactRepository file:/d:/myUS34 -installIU
myFeature34.feature.group -version 1.0.0 -destination
d:/eclipse_ganymede_RC4/eclipse_sdk -profile SDKProfile

!ENTRY org.eclipse.equinox.p2.engine 4 4 2008-06-17 09:20:58.252
!MESSAGE An error occurred while installing the items
!SUBENTRY 1 org.eclipse.equinox.p2.touchpoint.eclipse 4 0 2008-06-17
09:20:58.252
!MESSAGE The artifact file for myPlugin34/osgi.bundle/1.0.0 was not found.


After that I decided to remove all things and start from scratch. Create
again the plug-in, feature and update site. After using the following
command line it worked!

eclipsec.exe -application org.eclipse.equinox.p2.director.app.application
-metadataRepository file:/D:/motodev.us/ -artifactRepository
file:/D:/motodev.us/ -installIU motodev.feature.clicli.feature.group
-version 1.0.0 -destination D:/eclipse_ganymede_RC4/eclipse_sdk -profile
SDKProfile -vmArgs
-Declipse.p2.data.area=D:/eclipse_ganymede_RC4/eclipse_sdk/p2


Thanks for all support,

Pedro Carneiro.




Warren.Paul wrote:
> 
> Sorry, I'm not sure what might be going wrong.  I've always gotten some
> errors in the log when it fails.  Did you look in C:\Documents and
> Settings\<username>\workspace\.metadata? 
> 
> -----Original Message-----
> From: equinox-dev-bounces@xxxxxxxxxxx
> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of ext Pedro Carneiro
> Sent: Monday, June 16, 2008 11:12 AM
> To: equinox-dev@xxxxxxxxxxx
> Subject: RE: [equinox-dev] Calling p2 director by command
> linefreezesEclipseon splash screen
> 
> 
> I'm sorry but no logs were created by Eclipse.
> I searched for any log file existing in /configuration and /workspace,
> that is where it is usually created, but none was created.
> Any other suggestions are welcome. The only message that I have is from
> the command line (figure cl_screenshot.PNG cl_screenshot.PNG attached)
> just saying "Installation failed".
> 
> I also tried to install the feature using the complete command line (see
> image below) but the same error appear. No log file was created too.
> http://www.nabble.com/file/p17867896/error_using_eclipsec_complete.PNG
> error_using_eclipsec_complete.PNG 
> 
> In the same way, the Error log view does not show any error.
> 
> Thanks,
> 
> Pedro Carneiro.
> 
> 
> 
> 
> Warren.Paul wrote:
>> 
>> It should be logging errors in the error log 
>> (\workspace\.metadata\.log).  This will help figure out what went
> wrong.
>> Please locate this file, rename it to bak.log, run eclipsec.exe cmd 
>> line again, and post the contents of the new .log file here.  If 
>> you're not sure where to find the log file, you can start up 
>> eclipse.exe normally and Window->Show View->Error Log.
>> 
>> Thanks,
>> Warren
>> 
>> -----Original Message-----
>> From: equinox-dev-bounces@xxxxxxxxxxx
>> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of ext Pedro 
>> Carneiro
>> Sent: Monday, June 16, 2008 10:00 AM
>> To: equinox-dev@xxxxxxxxxxx
>> Subject: RE: [equinox-dev] Calling p2 director by command line 
>> freezesEclipseon splash screen
>> 
>> 
>> Hi Paul,
>> 
>> This time it worked really fast but returning an error.
>> I'm attaching the screenshots with the given error using both, 
>> eclipse.exe and eclipsec.exe.
>> I'm also attaching the command line screen and the given error when 
>> executing using eclipsec.exe.
>> 
>> Do you know what is happening?
>> 
>> Thanks,
>> 
>> Pedro Carneiro.
>> 
>> http://www.nabble.com/file/p17866361/cl_screenshot.PNG 
>> cl_screenshot.PNG
> http://www.nabble.com/file/p17866361/error_screenshot_using_eclipse.exe.
>> PNG
>> error_screenshot_using_eclipse.exe.PNG
>> http://www.nabble.com/file/p17866361/error_screenshot_using_eclipsec.e
>> xe
>> .PNG
>> error_screenshot_using_eclipsec.exe.PNG
>> 
>> 
>> 
>> 
>> Pedro Carneiro wrote:
>>> 
>>> Hi Paul,
>>> 
>>> Thanks for your reply.
>>> 
>>> I never tried to wait that much but I'll try right now and also the 
>>> eclipsec.exe alternative.
>>> As soon as I have this tested I'll report the results here.
>>> 
>>> Just to let you know, I'm trying to install only one feature 
>>> installation (just to test if the command line works), that is the 
>>> Hello World main menu example given on Eclipse plug-ins creation
>> wizard.
>>> 
>>> Thanks,
>>> 
>>> Pedro Carneiro.
>>> 
>>> 
>>> 
>>> 
>>> 
>>> Warren.Paul wrote:
>>>> 
>>>> Are you sure it's freezing?  From my experience it can take 10+ 
>>>> minutes to run, although we have a rather large set of features.
>>>> Maybe you can try running eclipsec.exe instead and giving it more
>> time?
>>>> 
>>>> Thanks,
>>>> Warren
>>>> 
>>>> -----Original Message-----
>>>> From: equinox-dev-bounces@xxxxxxxxxxx 
>>>> [mailto:equinox-dev-bounces@xxxxxxxxxxx] On Behalf Of ext Pedro 
>>>> Carneiro
>>>> Sent: Monday, June 16, 2008 8:14 AM
>>>> To: equinox-dev@xxxxxxxxxxx
>>>> Subject: [equinox-dev] Calling p2 director by command line freezes 
>>>> Eclipseon splash screen
>>>> 
>>>> 
>>>> Hi all,
>>>> 
>>>> I am trying to call the p2 director by command line to install a 
>>>> feature using p2 (I suppose this is the substitute of the old update
>> manager).
>>>> 
>>>> I was following the "Installing software using the p2 director 
>>>> application"
>>>> tutorial (available on Eclipse Help Contents > Platform Plug-in 
>>>> Developer Guide > Programmer's Guide > Packaging and delivering 
>>>> Eclipse based products
>>>>> Provisioning platform (p2)) but without success.
>>>> 
>>>> question 1: Is the mentioned tutorial out of date?
>>>> 
>>>> I'm using the command line below:
>>>> 
>>>> D:\eclipse_ganymede_RC4\eclipse>eclipse.exe -application 
>>>> org.eclipse.equinox.p2.director.app.application -metadataRepository
>>>> file:/d:/myUS34 -artifactRepository file:/d:/myUS34 -installIU 
>>>> myFeature34.feature.group -version 1.0.0 -destination 
>>>> d:/eclipse_ganymede_RC4/eclipse -profile SDKProfile
>>>> 
>>>> This command is freezing Eclipse in the splash screen. No log is 
>>>> created showing error messages, so I don't know what is happening.
>>>> 
>>>> Does anyone knows what could be rising this freeze?
>>>> 
>>>> Thanks,
>>>> 
>>>> Pedro Carneiro
>>>> --
>>>> View this message in context:
>>>> http://www.nabble.com/Calling-p2-director-by-command-line-freezes-Ec
>>>> l ips e-on-splash-screen-tp17864191p17864191.html
>>>> Sent from the Equinox - Dev mailing list archive at Nabble.com.
>>>> 
>>>> _______________________________________________
>>>> equinox-dev mailing list
>>>> equinox-dev@xxxxxxxxxxx
>>>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>>> _______________________________________________
>>>> equinox-dev mailing list
>>>> equinox-dev@xxxxxxxxxxx
>>>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>>>> 
>>>> 
>>> 
>>> 
>> 
>> --
>> View this message in context:
>> http://www.nabble.com/Calling-p2-director-by-command-line-freezes-Ecli
>> ps e-on-splash-screen-tp17864191p17866361.html
>> Sent from the Equinox - Dev mailing list archive at Nabble.com.
>> 
>> _______________________________________________
>> equinox-dev mailing list
>> equinox-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>> _______________________________________________
>> equinox-dev mailing list
>> equinox-dev@xxxxxxxxxxx
>> https://dev.eclipse.org/mailman/listinfo/equinox-dev
>> 
>> 
> 
> --
> View this message in context:
> http://www.nabble.com/Calling-p2-director-by-command-line-freezes-Eclips
> e-on-splash-screen-tp17864191p17867896.html
> Sent from the Equinox - Dev mailing list archive at Nabble.com.
> 
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> _______________________________________________
> equinox-dev mailing list
> equinox-dev@xxxxxxxxxxx
> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> 
> 

-- 
View this message in context: http://www.nabble.com/Calling-p2-director-by-command-line-freezes-Eclipse-on-splash-screen-tp17864191p17908126.html
Sent from the Equinox - Dev mailing list archive at Nabble.com.