[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Installer and agent data location


Note that there are command line options to the director for both the p2 data area and whether or not to install features.

See the help:
Platform Plug-in Developer Guide -> Programmer's Guide -? Packaging and delivering Eclipse based products -> Provisioning platform (p2) -> Installing software using p2 director application

In the Section "Installing a complete product", see the arguments:
-profileProperties org.eclipse.update.install.features=true
-vmargs
-Declipse.p2.data.area=D:/eclipse/p2

-Andrew


John Arthorne/Ottawa/IBM@IBMCA
Sent by: equinox-dev-bounces@xxxxxxxxxxx

06/11/2008 02:30 PM

Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
cc
Subject
Re: [equinox-dev] Installer and agent data location






Torkild/Pedro: I suggest entering bug reports to track these two issues. I'm not aware of existing bug reports about it.


John




Torkild Ulvøy Resheim <torkild.ulvoy-resheim@xxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

06/11/2008 10:13 AM

Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

To
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
cc
Subject
Re: [equinox-dev] Installer and agent data location








On Wed, 2008-06-11 at 06:57 -0700, Pedro Carneiro wrote:
> As you mentioned earlier, the /p2 directory is not created by the installer
> in the installation directory.
> I also noticed that the /p2 directory is created and updated [when the
> eclipse is running] in the install directory (the directory where the
> installer was).
> I think that the installer forget to move or, somehow, is not moving the /p2
> directory to the installation directory.
Yes, it looks like that. And if you delete the installer, your
installation will be broken and cannot be updated.
>
> 1. I did not find a bug for this. Is there one to keep me on track of this?
>
> In RC4, I noticed that the /features directory is back. The installer
> delivered in the RC4 is not creating the /features directory also.
The installer found in HEAD is not creating the features directory. That
is a result of setting IProfile.PROP_INSTALL_FEATURES of the profile to
"true". For our installer I've set this property
inInstallUpdateProductOperation.createProfile(). I have no idea if the
installer should install features or not.
>
> 2. I did not find a bug for this. Is there one to keep me on track of this?
>
> Thanks,
>
> Pedro Carneiro
I've not found any bugs to track these issues either. Could someone from
the p2 team please comment on this thread?

Regards,
Torkild

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev

_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev