[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] New version of Equinox quits upon bundle error

Hello!

I recently updated to 3.4M6, which IIUC is the most recent release.

I run my apps in the Eclipse console because it is great for debugging.
However, with this version, when one of my bundles has an error, everything
shuts down with a message "The Application could not start...".


How can I get the console to work like before and just run with the
erroneous bundles in a RESOLVED state so I can debug the problems?


BTW, the error logs are complaining that I need
org.eclipse.equinox.core.runtime installed. I don't mind installing one
bundle, but that bundle has lots of dependencies that I don't want.

I never needed this before... so what's changed?



Thank you!
David