[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Fw: p2 - help me find this bug!

Never mind...got it.
Funny how the mind thinks of new ideas right after a desperate cry for help.

susan
----- Forwarded by Susan Franklin McCourt/Beaverton/IBM on 04/30/2008 09:53 PM -----



          Susan Franklin McCourt

          04/30/2008 08:58 PM



To: equinox-dev@xxxxxxxxxxx
cc:
From: Susan Franklin McCourt/Beaverton/IBM@IBMUS
Subject: p2 - help me find this bug!

If you've been experiencing weird behavior with the
[ ] Include items that are installed
checkbox on the p2 Available Software page, can you please help me?

The relevant bug is
https://bugs.eclipse.org/bugs/show_bug.cgi?id=228794

When first reported, I could not reproduce it.
Then I saw it. Today I saw it most of the day while working on something else, and at some point it disappeared.
Now that I try to reproduce it, I don't see it.

So I believe it takes some setup to get into a state where you see the bug.
Or else something has been changing underneath me throughout the day that is affecting it.

Either
- there is some subtle bug in the UI that doesn't always manifest (most likely the case)
- there have been changes over the last few days in how a profile handles queries
- there have been changes over the last few days in how a profile instance is retrieved by id (ie, accidentally getting an out of date profile?)

If anyone has any leads, please annotate the bug.
I'll try again tomorrow with fresh eyes, fresh workspace, fresh build.

thanks,
susan

GIF image