[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] [p2] plug-in versions

My 2 cents ...

For Ganymede the plan is to have 1.0 p2 functionality. This should not imply that we will have p2 1.0 API. I imagine for the first release of p2 we are going to have lots of bundles start to use the internal.provisional APIs because there is no public API available and they will have to resort to using the internal.provisional APIs. I suggest we release with all p2 bundle versions as 1.0. When we graduate to real API for p2 then the bundles can be increased to 2.0.

This way we can recommend a version range of [1.0, 2.0) for early adopters use internal.provisional API. In a future release when p2 does include real API then the early adopters will be able to clearly see which bundles graduated real API. I suppose the same can be done with 0.1.0 versions with a range of [0.1.0, 1.0) and [1.0, 2.0) after the real API is introduced. But a bundle version of 0.1.0 does not give the impression that p2 is releasing 1.0 functionality in Ganymede.

Tom



Inactive hide details for John Arthorne ---04/14/2008 07:31:09 AM---I don't think we ever decided on this. The thinking was thaJohn Arthorne ---04/14/2008 07:31:09 AM---I don't think we ever decided on this. The thinking was that since no API was being declared, we might leave the plug-ins with


From:

John Arthorne <John_Arthorne@xxxxxxxxxx>

To:

Equinox development mailing list <equinox-dev@xxxxxxxxxxx>

Date:

04/14/2008 07:31 AM

Subject:

Re: [equinox-dev] [p2] plug-in versions





I don't think we ever decided on this. The thinking was that since no API was being declared, we might leave the plug-ins with a number < 1.0 and then move to 1.0 in the first release that contains real API (likely 3.5). Typically the initial API of a plug-in appears in version 1.0 of the plug-in.



Chris Aniszczyk <zx@xxxxxxxxxx>
Sent by: equinox-dev-bounces@xxxxxxxxxxx

04/10/2008 07:23 PM

Please respond to
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
To
Equinox development mailing list <equinox-dev@xxxxxxxxxxx>
cc
Subject
[equinox-dev] [p2] plug-in versions




I noticed that all of p2 plug-ins are currently 0.10.qualifier... shouldn't this be 1.0.0.qualifier since these have been graduated and will be included in the SDK for 3.4?

I ask this as I'm trying to straighten out some plug-in dependency ranges in PDE.

Cheers,

---
Chris Aniszczyk | IBM Lotus | Eclipse Committer |
http://mea-bloga.blogspot.com | +1.860.839.2465_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev
_______________________________________________
equinox-dev mailing list
equinox-dev@xxxxxxxxxxx
https://dev.eclipse.org/mailman/listinfo/equinox-dev

GIF image

GIF image