[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] Equinox p2 -Problem running director app from the Getting Started for Developers Guide

All --

I have been trying to work through the Getting Started for Developers Guide( http://wiki.eclipse.org/Equinox_p2_Getting_Started_for_Developers<http://wiki.eclipse.org/Equinox_p2_Getting_Started_for_Developers%20>) and I'm having a problem running the  director app part of the setup.

I have downloaded the src code for p2 and built the project based on the steps listed in the guide.
I have successfully run the Metadata Generator SDK and had it do its work against a 3.3 eclipse instance that I had previously installed.

When running the director app in the next step of the guide, I get the following exception.....


osgi> !SESSION 2008-02-21 12:35:51.494 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.5.0_12
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments:  -application org.eclipse.equinox.p2.director.app.application -metadataRepository file:C:\equinox.p2\servers\ -artifactRepository file:C:\equinox.p2\servers\ -installIU sdk -destination C:\equinox.p2\eclipseApp\ -flavor tooling -profile foo
Command-line arguments:  -dev file:C:/jehamm/dev/open_source/.metadata/.plugins/org.eclipse.pde.core/director app/dev.properties -console -consolelog -application org.eclipse.equinox.p2.director.app.application -metadataRepository file:C:\equinox.p2\servers\ -artifactRepository file:C:\equinox.p2\servers\ -installIU sdk -destination C:\equinox.p2\eclipseApp\ -flavor tooling -profile foo

!ENTRY org.eclipse.osgi 4 0 2008-02-21 12:35:52.212
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
        at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:72)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:362)
        at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:175)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
        at java.lang.reflect.Method.invoke(Unknown Source)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:564)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1251)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1227)


I found this link
http://permalink.gmane.org/gmane.comp.ide.eclipse.equinox.devel/2644
which describes what may be the problem and followed the bugzilla defect. It appears to have been fixed in 3.4M4 timeframe.

I have subsequently downloaded the eclipse source and examined the files that the bugzilla referenced and do not see the changes in the source I downloaded.
I assume that I have the wrong 3.4M5 downloaded? This is the link I got the 3.4M5 src from.
http://mirror.calvin.edu/eclipse/downloads/drops/S-3.4M5-200802071530/index.php
        Source Build (Source in .zip) (instructions<http://mirror.calvin.edu/eclipse/downloads/drops/S-3.4M5-200802071530/srcIncludedBuildInstructions.html>)   (http)<http://mirror.calvin.edu/eclipse/downloads/drops/S-3.4M5-200802071530/download.php?dropFile=eclipse-sourceBuild-srcIncluded-3.4M5.zip>   93 MB   eclipse-sourceBuild-srcIncluded-3.4M5.zip       (md5)<http://download.eclipse.org/eclipse/downloads/drops/S-3.4M5-200802071530/checksum/eclipse-sourceBuild-srcIncluded-3.4M5.zip.md5> (sha1)<http://download.eclipse.org/eclipse/downloads/drops/S-3.4M5-200802071530/checksum/eclipse-sourceBuild-srcIncluded-3.4M5.zip.sha1>

and here is how I got the p2 code .

1.

Create a CVS repository location for ":pserver:anonymous@xxxxxxxxxxxxxxx:/cvsroot/eclipse".
2.      Expand HEAD > equinox-incubator > provisioning
3.      Checkout "org.eclipse.equinox.p2.releng"
4.      Import the "projectSet.psf" project set using File > Import > Team Project Set in the releng project you just checked out.

Is this correct, or can anyone provide the correct links to work from?

Thanks --
Jeff

Here is the information in the Help->About Eclipse SDK that I am invoking the director app from.

Eclipse SDK

Version: 3.4.0
Build id: I20080207-1530