[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
[equinox-dev] the importance of targetting Foundation JREs

In the past couple days there have been at least three cases of code problems that where either code from J2SE was being used or dependencies were spec’d incorrectly because stuff was coming for free from the JRE.  We can avoid these simply by installing and configuring a Foundation 1.1 JRE.  See

                http://wiki.eclipse.org/index.php/J9#Foundation_1.1

for details on how to do this.  I would have thought that the builds would pick this up but perhaps they do not have foundation JREs either.  I’ll open a bug for that.

 

Jeff