[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] [List Home]
Re: [equinox-dev] Launch Eclipse using Equinox

Jacek,
maybe I can help out with a possible explanation...

If you are looking into the config.ini file of 1) or 2) you will find an entry 
with 'gtk' as WS. This wrong entry was caused by a wrong definition in those 
early package builds and has been fixed since then.

Markus


On Friday 28 December 2007 19:15, Jacek PospychaÅa wrote:
> William,
> you're right, I reproduced this as well.
> Maybe the problem is that when using launcher_1.0.0, log contains:
>
> BootLoader constants: OS=win32, ARCH=x86, WS=gtk, NL=pl_PL
>
> (Notice WS=gtk - in Windows?).
> Whereas with launcher_1.0.100, log looks more reasonable:
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=pl_PL
>
> That would answer the question, why log file contains lines like:
> !MESSAGE Bundle
> update@plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.0.v20070523
>/ [58] was not resolved.
> !SUBENTRY 2 org.eclipse.equinox.launcher.win32.win32.x86 2 0 2007-12-28
> 18:59:45.421
> !MESSAGE Platform filter did not match: (& (osgi.ws=win32)
> (osgi.os=win32) (osgi.arch=x86))
>
> I couldn't find any bugzilla for this, but issue seems fixed for more
> recent versions of launcher. Would it be possible that you used more
> recent launcher?
>
> William.Fulton@xxxxxxx wrote:
> > Eclipse starts perfectly using eclipse.exe. I used the Cmd/Bat Script
> > at the end of that Wiki page and ran it in the root eclipse directory
> > (where eclipse.exe lives).
> >
> > The problem seems to be the version of Eclipse. I was using the
> > original Europa. If you download this, you should be able to
> > replicate:
> > http://ftp.sh.cvut.cz/MIRRORS/eclipse/technology/epp/downloads/release/20
> >070702/eclipse-java-europa-win32.zip
> >
> > I originally tried this version without any luck as well as this
> > version updated using the Help, Software Updates, Find and Install,
> > Search for updates of the currently installed features. This updated
> > it to 3.3.1.1 Build-ID: M20071023-1652. This also did not work. I then
> > downloaded eclipse-java-europa-fall2-win32.zip (20071103) and
> > everything now works.
> >
> > If you can replicate the problem with the 20070702 Europa version (it
> > shouldn't take long to download and try it out), I suggest we update
> > the wiki page. It also looks like the software updater is not working
> > properly as something that Equinox depends on is not being properly
> > updated.
> >
> > FYI, the versions of the Equinox launcher are:
> >
> > 1) Original Europa 20070702:
> > org.eclipse.equinox.launcher_1.0.0.v20070606.jar
> >
> > 2) Europa 20070702 updated to 3.3.1.1:
> > org.eclipse.equinox.launcher_1.0.0.v20070606.jar
> > org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
> >
> > 3) Europa 20070927 (eclipse-java-europa-fall-win32.zip)
> > org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
> >
> > 3) Europa 20071103 (3.3.1.1) (eclipse-java-europa-fall2-win32.zip)
> > org.eclipse.equinox.launcher_1.0.1.R33x_v20070828.jar
> >
> > Neither 1) or either jar in 2) worked for me, but 3) and 4) did.
> > Strange because 2), 3) and 4) use the same jar.
> >
> > William
> >
> > ------------------------------------------------------------------------
> > *From:* equinox-dev-bounces@xxxxxxxxxxx
> > [mailto:equinox-dev-bounces@xxxxxxxxxxx] *On Behalf Of *Jacek Pospychala
> > *Sent:* 27 December 2007 16:59
> > *To:* Equinox development mailing list
> > *Subject:* Re: [equinox-dev] Launch Eclipse using Equinox
> >
> > Hi,
> >
> > Is it possible that you're missing swt fragment? It should be
> > something like plugins/org.eclipse.swt.win32.win32.x86-version
> > I have tried this to start Eclipse:
> > java -cp plugins/org.eclipse.equinox.launcher_1.0.100.v20071029.jar
> > org.eclipse.equinox.launcher.Main
> >
> > If that won't help:
> > Did you get Eclipse from www.eclipse.org?
> > What exactly did you tried to start Eclipse?
> > Does Eclipse start correctly when you use eclipse.exe?
> >
> > William.Fulton@xxxxxxx wrote:
> >> The instructions on the wiki to launch Eclipse using Equinox are not
> >> working for me for Eclipse Europa:
> >> _http://wiki.eclipse.org/Starting_Eclipse_Commandline_With_Equinox_Launc
> >>her_. I've tried this on a couple of Windows XP SP2 boxes. Are these
> >> instructions up to date? The exceptions that appear in the Eclipse
> >> log are shown below:
> >>
> >>
> >> !SESSION 2007-12-27 16:00:58.733
> >> -----------------------------------------------
> >> eclipse.buildId=I20070625-1500
> >> java.version=1.5.0_07
> >> java.vendor=Sun Microsystems Inc.
> >> BootLoader constants: OS=win32, ARCH=x86, WS=gtk, NL=en_GB
> >>
> >> !ENTRY org.eclipse.osgi 4 0 2007-12-27 16:01:02.280
> >> !MESSAGE An error occurred while automatically activating bundle
> >> org.eclipse.ui.workbench (313).
> >> !STACK 0
> >> org.osgi.framework.BundleException: The activator
> >> org.eclipse.ui.internal.WorkbenchPlugin for bundle
> >> org.eclipse.ui.workbench is invalid
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActiva
> >>tor(AbstractBundle.java:141)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleC
> >>ontextImpl.java:970)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHo
> >>st.java:346)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBu
> >>ndle.java:260)
> >>
> >>         at
> >> org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400
> >>)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLoc
> >>alClass(EclipseLazyStarter.java:111)
> >>
> >>         at
> >> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(Clas
> >>spathManager.java:417)
> >>
> >>         at
> >> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(
> >>DefaultClassLoader.java:189)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(Bun
> >>dleLoader.java:340)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(S
> >>ingleSourcePackage.java:37)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(
> >>BundleLoader.java:405)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLo
> >>ader.java:369)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLo
> >>ader.java:357)
> >>
> >>         at
> >> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(Defau
> >>ltClassLoader.java:83)
> >>
> >>         at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> >>         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
> >>         at java.lang.Class.getDeclaredConstructors0(Native Method)
> >>         at
> >> java.lang.Class.privateGetDeclaredConstructors(Class.java:2328)
> >>         at java.lang.Class.getConstructor0(Class.java:2640)
> >>         at java.lang.Class.newInstance0(Class.java:321)
> >>         at java.lang.Class.newInstance(Class.java:303)
> >>         at
> >> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecu
> >>tableExtension(RegistryStrategyOSGI.java:170)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExt
> >>ension(ExtensionRegistry.java:788)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElement.createExecutable
> >>Extension(ConfigurationElement.java:243)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElementHandle.createExec
> >>utableExtension(ConfigurationElementHandle.java:51)
> >>
> >>         at
> >> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.j
> >>ava:165)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplicat
> >>ion(EclipseAppLauncher.java:106)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Eclip
> >>seAppLauncher.java:76)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>363)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>176)
> >>
> >>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >>         at
> >> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
> >>a:39)
> >>
> >>         at
> >> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
> >>Impl.java:25)
> >>
> >>         at java.lang.reflect.Method.invoke(Method.java:585)
> >>         at
> >> org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
> >>         at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> >>         at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
> >>         at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
> >> Caused by: java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
> >>         at java.lang.Class.getDeclaredConstructors0(Native Method)
> >>         at
> >> java.lang.Class.privateGetDeclaredConstructors(Class.java:2328)
> >>         at java.lang.Class.getConstructor0(Class.java:2640)
> >>         at java.lang.Class.newInstance0(Class.java:321)
> >>         at java.lang.Class.newInstance(Class.java:303)
> >>         at
> >> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActiva
> >>tor(AbstractBundle.java:136)
> >>
> >>         ... 37 more
> >> Root exception:
> >> java.lang.NoClassDefFoundError: org/eclipse/swt/SWTError
> >>         at java.lang.Class.getDeclaredConstructors0(Native Method)
> >>         at
> >> java.lang.Class.privateGetDeclaredConstructors(Class.java:2328)
> >>         at java.lang.Class.getConstructor0(Class.java:2640)
> >>         at java.lang.Class.newInstance0(Class.java:321)
> >>         at java.lang.Class.newInstance(Class.java:303)
> >>         at
> >> org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActiva
> >>tor(AbstractBundle.java:136)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleC
> >>ontextImpl.java:970)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHo
> >>st.java:346)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBu
> >>ndle.java:260)
> >>
> >>         at
> >> org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400
> >>)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLoc
> >>alClass(EclipseLazyStarter.java:111)
> >>
> >>         at
> >> org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(Clas
> >>spathManager.java:417)
> >>
> >>         at
> >> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(
> >>DefaultClassLoader.java:189)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(Bun
> >>dleLoader.java:340)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(S
> >>ingleSourcePackage.java:37)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(
> >>BundleLoader.java:405)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLo
> >>ader.java:369)
> >>
> >>         at
> >> org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLo
> >>ader.java:357)
> >>
> >>         at
> >> org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(Defau
> >>ltClassLoader.java:83)
> >>
> >>         at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
> >>         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
> >>         at java.lang.Class.getDeclaredConstructors0(Native Method)
> >>         at
> >> java.lang.Class.privateGetDeclaredConstructors(Class.java:2328)
> >>         at java.lang.Class.getConstructor0(Class.java:2640)
> >>         at java.lang.Class.newInstance0(Class.java:321)
> >>         at java.lang.Class.newInstance(Class.java:303)
> >>         at
> >> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecu
> >>tableExtension(RegistryStrategyOSGI.java:170)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExt
> >>ension(ExtensionRegistry.java:788)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElement.createExecutable
> >>Extension(ConfigurationElement.java:243)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElementHandle.createExec
> >>utableExtension(ConfigurationElementHandle.java:51)
> >>
> >>         at
> >> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.j
> >>ava:165)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplicat
> >>ion(EclipseAppLauncher.java:106)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Eclip
> >>seAppLauncher.java:76)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>363)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>176)
> >>
> >>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >>         at
> >> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
> >>a:39)
> >>
> >>         at
> >> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
> >>Impl.java:25)
> >>
> >>         at java.lang.reflect.Method.invoke(Method.java:585)
> >>         at
> >> org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
> >>         at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> >>         at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
> >>         at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
> >>
> >> !ENTRY org.eclipse.osgi 4 0 2007-12-27 16:01:02.296
> >> !MESSAGE Application error
> >> !STACK 1
> >> org.eclipse.core.runtime.CoreException: Plug-in
> >> "org.eclipse.ui.ide.application" was unable to instantiate class
> >> "org.eclipse.ui.internal.ide.application.IDEApplication".
> >>
> >>         at
> >> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.throwExcept
> >>ion(RegistryStrategyOSGI.java:180)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecu
> >>tableExtension(RegistryStrategyOSGI.java:174)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExt
> >>ension(ExtensionRegistry.java:788)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElement.createExecutable
> >>Extension(ConfigurationElement.java:243)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElementHandle.createExec
> >>utableExtension(ConfigurationElementHandle.java:51)
> >>
> >>         at
> >> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.j
> >>ava:165)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplicat
> >>ion(EclipseAppLauncher.java:106)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Eclip
> >>seAppLauncher.java:76)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>363)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>176)
> >>
> >>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >>         at
> >> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
> >>a:39)
> >>
> >>         at
> >> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
> >>Impl.java:25)
> >>
> >>         at java.lang.reflect.Method.invoke(Method.java:585)
> >>         at
> >> org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
> >>         at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> >>         at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
> >>         at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
> >> org.eclipse.core.runtime.CoreException[1]:
> >> java.lang.NoClassDefFoundError:
> >> org/eclipse/ui/application/WorkbenchAdvisor
> >>         at java.lang.Class.getDeclaredConstructors0(Native Method)
> >>         at
> >> java.lang.Class.privateGetDeclaredConstructors(Class.java:2328)
> >>         at java.lang.Class.getConstructor0(Class.java:2640)
> >>         at java.lang.Class.newInstance0(Class.java:321)
> >>         at java.lang.Class.newInstance(Class.java:303)
> >>         at
> >> org.eclipse.core.internal.registry.osgi.RegistryStrategyOSGI.createExecu
> >>tableExtension(RegistryStrategyOSGI.java:170)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ExtensionRegistry.createExecutableExt
> >>ension(ExtensionRegistry.java:788)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElement.createExecutable
> >>Extension(ConfigurationElement.java:243)
> >>
> >>         at
> >> org.eclipse.core.internal.registry.ConfigurationElementHandle.createExec
> >>utableExtension(ConfigurationElementHandle.java:51)
> >>
> >>         at
> >> org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.j
> >>ava:165)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplicat
> >>ion(EclipseAppLauncher.java:106)
> >>
> >>         at
> >> org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(Eclip
> >>seAppLauncher.java:76)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>363)
> >>
> >>         at
> >> org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:
> >>176)
> >>
> >>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >>         at
> >> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
> >>a:39)
> >>
> >>         at
> >> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
> >>Impl.java:25)
> >>
> >>         at java.lang.reflect.Method.invoke(Method.java:585)
> >>         at
> >> org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:508)
> >>         at org.eclipse.equinox.launcher.Main.basicRun(Main.java:447)
> >>         at org.eclipse.equinox.launcher.Main.run(Main.java:1173)
> >>         at org.eclipse.equinox.launcher.Main.main(Main.java:1148)
> >>
> >> !ENTRY org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE The following is a complete list of bundles which are not
> >> resolved, see the prior log entry for the root cause if it exists:
> >>
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/org.eclipse.ui.win32_3.2.100.I20070319-0010.jar [162]
> >> was not resolved.
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/de.walware.statet.r.launching.winrgui_0.4.0.b200710240830
> >>sw.jar [222] was not resolved.
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.2.R331_v
> >>20071019/ [268] was not resolved.
> >>
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/org.eclipse.jdt.apt.pluggable.core_1.0.1.R33x_v20070831-0
> >>435.jar [276] was not resolved.
> >> !SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2007-12-27
> >> 16:01:02.749
> >> !MESSAGE Missing imported package
> >> org.eclipse.jdt.internal.compiler.tool_0.0.0.
> >> !SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2007-12-27
> >> 16:01:02.749
> >> !MESSAGE Missing imported package
> >> org.eclipse.jdt.internal.compiler.apt.dispatch_0.0.0.
> >> !SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2007-12-27
> >> 16:01:02.749
> >> !MESSAGE Missing imported package
> >> org.eclipse.jdt.internal.compiler.apt.model_0.0.0.
> >> !SUBENTRY 2 org.eclipse.jdt.apt.pluggable.core 2 0 2007-12-27
> >> 16:01:02.749
> >> !MESSAGE Missing imported package
> >> org.eclipse.jdt.internal.compiler.apt.util_0.0.0.
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/org.eclipse.jdt.compiler.apt_1.0.1.R33x_v20070831-0435.ja
> >>r [278] was not resolved.
> >> !SUBENTRY 2 org.eclipse.jdt.compiler.apt 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Missing imported package
> >> org.eclipse.jdt.internal.compiler.tool_0.0.0.
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/org.eclipse.jdt.compiler.tool_1.0.1.v_780_R33x.jar
> >> [279] was not resolved.
> >> !SUBENTRY 1 org.eclipse.osgi 2 0 2007-12-27 16:01:02.749
> >> !MESSAGE Bundle
> >> update@plugins/org.eclipse.swt.win32.win32.x86_3.3.2.v3347a.jar [298]
> >> was not resolved.
> >>
> >> Any suggestions to get this working are much appreciated.
> >>
> >> William
> >>
> >> ------------------------------------------------------------------------
> >>
> >> _______________________________________________
> >> equinox-dev mailing list
> >> equinox-dev@xxxxxxxxxxx
> >> https://dev.eclipse.org/mailman/listinfo/equinox-dev
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > equinox-dev mailing list
> > equinox-dev@xxxxxxxxxxx
> > https://dev.eclipse.org/mailman/listinfo/equinox-dev